Recently, several members of the Russian http://www.player.ru/talk/ forum (including myself) discovered that their RH1s take ages to upload SP. A full SP disc took 50-100 minutes to upload. Yesterday, a member named fsw discovered that this occurs after plugging in an older NetMD unit to the computer you are using for RH1 uploads, and found out that removing all NetMD drivers and plugging the RH1 in again solves the problem. I'll expand on this a bit more. The problem seems to be caused by some conflict between the driver for the "fast" RH1 (NETMD052.sys), and drivers for older "slow" models (NETMDUSB.sys, NETMD031.sys, and NETMD033.sys), which are designed for NetMD downloading only. If you plug in an older unit, it installs its driver, which then doesn't allow the RH1 to upload at full speed. The complete solution is the first five steps of the solution to the "Walkman device detection issue", which I posted before. I'll repeat the five steps here, with an update to Step 1, which is absolutely essential: Disconnect any ATRAC devices from your PC and close SonicStage. Restart your computer. Go to Control Panel->System->Advanced->Environment Variables. Under the "User variables for [your username]" field, press the New... button, and create the variable (exactly as shown, without quotation marks): "devmgr_show_details", set it equal to 1, press OK, press the New... button again, then create the "devmgr_show_nonpresent_devices" variable, and also set it equal to 1 and press OK. Press OK again to save the variables and exit the window. Go to Device Manager, and enable the View->Show hidden devices option. Find and remove all "phantom" (semi-transparent) instances of "Net MD", "Sony USB Device" (in Universal Serial Bus controllers), "SONY Hi-MD WALKMAN USB Device" (in Disk drives), and "Generic volume" (in Storage volumes). Do not remove any Generic volumes which are not semi-transparent - these are your hard drives!!! Then plug in your RH1 with an SP disc inside, it will install its driver, and upload at full speed again. And avoid plugging in older units to the same computer again.