Sign in to follow this  
Followers 0
jimbr

Headphone jack suddenly dead on MDS-S707

Rate this topic

2 posts in this topic

Hi - my headphone jack suddenly went dead on my MDS-S707... Is this from say a blown fuse? Just happened out of the blue. Any help would be appreciated. Thanks!

Share this post


Link to post
Share on other sites

Hard to say. Do you know anyone who is smart with soldering? I recommend that person, or an electronics repairman, orrrrr yourself if you are fearless. The stuff still feels like the wave of the future but I have to keep reminding myself how old this stuff really is. And most of it was NOT made to self destruct. So it has lasted really well but I guess there will be some odd breaks here and there. One easy thing to do is to look into the headphone jack for debris. Try to clean it out with a canned air duster. Also if you are brave, try to open it enough to look for a broken wire leading away from the jack on the inside. It might be a solder issue also. I'd say the easiest fix if possible is to use the line out jack if the player has one. Or,... maybe eBay a new one? I bet someone out there also has to have good advice?

Or.... as silly as it sounds... try turning the volume up or look for any kind of weird function the player has... it try a different MD or think about any kind of possible user error before tearing that sucker open just to avoid any self face-palming or lost cash/equipment.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0