Jump to content

SONY MZ-R900 charging problem

Rate this topic


Recommended Posts

I recently pulled out my MZ-R900 to see if it was still operational.

When I tried to charge the battery, the charging message comes up, but the screen immediately goes blank.

Any suggestions?

I have not used it in about two years.

I tried the replacement battery I had been using as well as the original battery.



Link to comment
Share on other sites

Try inspecting/cleaning the battery contacts on the battery and the unit itself.

There was some oxidation, but no change in the result.

Would a totally dead battery prevent the charging?

I don't want to invest in a new battery if the unit is toast.

Anyone have an old battery they would donate to the cause?

A cheap new battery source would also be appreciated.

I also would be in the market for a battery charger is someone wanted to unload one.



Edited by the Grape
Link to comment
Share on other sites

  • 4 weeks later...

NH-14WM - regular gum stick

I am planning to pull out my old mz-r900 soon, and expect to have the same problem.

When I first bought it (second hand), there was very minor oxidation on the terminal that pops out when you open the gumstick battery compartment. I scrubbed it all clean but no joy. When I plugged in to charge it would show up the "charging" message but would only work for seconds once I tried it on battery alone. I replaced the battery and the same thing happened. Eventually it seemed as if there just was not a good contact with the terminal, and this was confirmed because I could "squeeze" the top of the player (ie grip it at either end, where the terminals would be, and it would work normally until I relaxed the pressure.

So I just found some copper wire and twisted it into a strand, and popped it in on top of the terminal when I closed the compartment. I used just enough wire so that there was a snug fit, and it worked fine.

I think part of the problem was an old battery as well, but improving the terminal connections was a big help. This time around I might do the same thing, or maybe place just a little bit of solder onto the terminal.

Link to comment
Share on other sites

Using a MZR 900 since 2001, and never get this problem.. anyway I had to quy a new gumstick and here, in Italy, it's very cheap (12E) so I think it's worth for such a superb unit!! (Sometimes it kicks the rh1 in SQ).

Anyway, I got this problem: when the unit is off for a while, when operating the display doesn't work.. it doesn't display anything.. any ideas? maybe this is also your problem?

Link to comment
Share on other sites

  • 12 years later...

So ... got out my 20 year old MZ-R900.  Works perfect other than not charging battery.  Tried new battery, no better.  Tried using a strip of copper wire ...ta-daa! working.   One thing I noticed on my device is that there is a crack in the battery cover that means there isn't full pressure on the battery terminal.  I cleaned the copper terminal, cut a 10mm piece of copper wire and bent it into tight U shape.  Then hooked it under the spring section of the terminal in the cover (so it stays in place).  Now it charges!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...