Jump to content



Recommended Posts

  • Replies 517
  • Created
  • Last Reply

Top Posters In This Topic

I got it all sorted :) The songs are playing, i have a fresh database to start again, and i have the winamp plugin which is far better and faster than sonicstage! Thanks alot for your help and for these wonderful programs :)

EDIT: So it looks like it didn't work. Half way through transferring some albums, i got the "System 32 Error" Now it doesn't recognise my player, and i can't get any thing on to it because there is 0gb free :sad:

I tried deleting the OMGAUDIO folder and starting again. But i really don't want to format, it took me about a day to copy all the temp files and and generate the decodekey.

Any help?

Edited by H3LL_F1R3
Link to comment
Share on other sites

Try to create an OMGAUDIO directory and create an empty file named "04CNTINF.DAT" in it. Then start winamp

Or :

Just copy the decodeKey somewhere, keep it safe it will always be the same key for that player, (you can just copy your GYM directory it should not be very big)

you can then format, recopy your keycode, and start again.

The "System 32 Error" is probably an unrecognize format or id3 tag causing failure during the transfert. If you can Isolate which file is causing problem, please send it to me.

Edited by otiasj
Link to comment
Share on other sites

Ok, thanks, i'll give this a go and let you know

EDIT: Ok, i copied everything to my PC, and formated, then created the OMGAUDIO folder and the .dat file again. It is now recognising my player in winamp with the 18. gb.

I am now copying all the GYM files back on, and hopefully it should work again.

But i am a little cautious. I don't want to get say 2000 songs on there and then one file that it can't read causes the win32 error meaning i would have to format again :mellow:

I'm going to put one album on at a time to be a bit safer and if it DOES happen again, i'll let you know. and it should be a bit more narrowed down

EDIT 2: I copied all the GYM files back, but the tracks are still unreadable. does this mean i am going to have to go through the whole GYM coding again?

EDIT 3: After a full new keycoding session, (ehich didn't work first time) and some reformating and copying later... I finally got music on to my player that played. I am using MP3FM this time, which may be the reason I'm not quite sure, but i will stick to it, an album at a time.

Thanks for your help

Edited by H3LL_F1R3
Link to comment
Share on other sites


firstly thanks for your hard work

i have a problem

the first time i used the plugin it worked spot on transfered over 2k songs but i have just been to try and add a few more albums and when i select the album. right click .add to sony walkman. but the songs dont transfer. am i doing something wrong? do i have to delete all the songs then put all them back on?

thanks for any help in advance cheers jay

EDIT:its started to work not sure why but im happy

Edited by part time hero
Link to comment
Share on other sites

dobiedo :

Never tested ml_sony on vista, probably a write access problem,

the tracks are written to c:

maybe vista UAC prevents you to do that?

In any case sorry I don't own a vista copy at the moment so it will be some time until I can fix this.

Edited by otiasj
Link to comment
Share on other sites


I think it's possible to solve this problem by giving the possibility to configure the destination drive..perhaps in the next release! :)It will be cool for every one

(even those I can't understand the choice of vista... :unsure: ...my biggest wish is to bring this wonderful plugin to Linux and the amazing Amarok)

PS: sorry If my english suxx a bite..I'm french

Edited by Garth
Link to comment
Share on other sites

just an observation (possibly a quirk in my system) but is any one else having a problem with the ML_Sony plugin with the new winamp 5.34 version. i find there is graphical corruption (i.e. missing buttons) of the interface.

Not only were my buttons messed up, the plugin did not even work. I could right-click and add to walkman, but no tracks were ready to transfer when I then clicked on the walkman.

Just gone back to 5.33 and running smoothly.

Link to comment
Share on other sites

Not only were my buttons messed up, the plugin did not even work. I could right-click and add to walkman, but no tracks were ready to transfer when I then clicked on the walkman.

Just gone back to 5.33 and running smoothly.

yes that is the same as i did. it's not just my system then

Link to comment
Share on other sites

  • 2 weeks later...

Hello everyone,

Falling animals : no there is no way to do that at the time, and since I don't own a device that can display album art. I won't be able to develop it. However if someone knows a open source soft that can do the trick I will try to add it to the plugin.

Concerning the 5.34 problem, I did not get a chance to test it yet, I will see what I can do.

The new library is almost complete, so I will need some beta testers to test it.

It won't be a winamp plugin but a separate program just to test the compatibility.

I will probably release it somewhere next month.

stay tuned! ^^

Link to comment
Share on other sites


It should not be hard to test. But I will need has many different devices as possible

For a port to linux it can be done, it's just that I don't have the time to do it myself.

Plus I think there is already a couple of solution on linux.

You are welcome to start a branch to the project

#et au fait c'est quoi ce complexe d'être Français? ^-^

Link to comment
Share on other sites

If it doesn't mater any one I will answer to otiasj in French :D It's not so often to met French

d'abord je ferai sûrement moins de fautes... puis c'est vrai que c'est assez agréble de voir parler francais des fois sur ce genre de fourm ;)

Alors juste parce que ca fais plaisir je vais continuer en francais! après promis je reparlerai en englais pour que tout le monde comprenne.

Juste déjà si tu as 2 3 noms pour des équivalent sous linux ca m'intéresse.

Ensuite pour ce qui est de développer pour linux je me doute bien que c'est le temps qui doit manquer..

et personnellement je me jetterai bien à l'eau but as I have send you a mail to your "voila" account (a while ago), I would love to contribute to this project

and I have took a look to the SVN repository but my programming skill is a bit limited.

And i didn't understand a lot. My best dream was those were comment much more...

Perhaps with a lite help I should take a look deeper during my summer's night.(ouhh ca sent le looser ca .. :D)

Edited by Garth
Link to comment
Share on other sites

Hello everyone,

for the developpers of plugins using sonydb or developpers willing to help on the code,

I have uploaded the library code to the source forge svn server, feel free to have look.

This time I am using visual studio 2005


Link to comment
Share on other sites

I feel stupid but I just can't get the plugin working at all.




- nocode.txt

OMGAUDIO2 // the backup

Sending a song to E:Sony Walkman (which is listed in Winamp under "Devices") does nothing.

Also I can't see a button "Apply" you've mentioned couple of times.

I'm using WinAmp 5.33 with Media Library, ml_sony103.zip, Win2k.

Any ideas PLZ?

Edited by yaroukh
Link to comment
Share on other sites

Hello, have a problem.

The apply button does not appear anymore. I used ml_sony for several months with no problems at all, I know how to use it, always worked. A while ago I reinstalled windows xp and had to reinstall winamp as well (version 5.35 now). But I'm not sure if it stopped to work because of this. I could play the songs on the device via ml, also could download and delete them, but couldn't add any new songs. I initialized, replaced all the necessary files, replaced ml_sony plugin file. It is still not working.

A friend also uses ml_sony, and she suddenly has the same problem, apply button does not appear and the config button does not show any info window. Not sure which version of winamp she has.

I stupidly deleted the log file, in my quest to reset evrything.

Don't know how to make a screenshot, if necessary, I will find out.

Has it to do with new winamp version 5.35? And when it does, where can I find an older version, and which version do I need?

Someone else had this problem?

Thanks in advance!

Edit: OK, it is the winamp version. Should have read the link of otiasj earlier, just right above. Try to find an older version now.

Edited by Koo
Link to comment
Share on other sites

Hello everybody!

So I permit me to resume for now who is voluntary for testing the next release of ml_sony:

dotslash => NW-S205F

markd => NWA-3000

Garth => NWA-1200

groar => NW-HD5

cautious => NW-HD5

There it is for the moment! (9/6/07 à 00h42) I hope there will be more beta tester!

I will post a message to generation-mp3 (where i have found this plugin :D) perhaps there will be some more beta tester here!



edit: sorry their forum suxx i can't create anything

edit':One more! here you are in the volontary beta tester's list groar!! :P and I had forgotten cautious ..

Edited by Garth
Link to comment
Share on other sites

yes i will do testig as havee huge libary ofmp3s. Current plug in with 5.33 works well and is reasonably stable. Winamp occassional hang ups if I try and transfer over 100 tracks in one go.

SS4,3 underr vista works very slowwwwwww and sometimes fails to respond. I album can take 8 mins. under xp ok but flakey with so many trachs 200gg.

so the reason why i use ml_sny

Link to comment
Share on other sites

Hello Everybody!

Just got my new NW-A808 today, and would REALLY like to see it work with WinAmp as my Creative Zen Micro does. I have used SonicStage for 5 minutes, and already hate the fact that I HAVE TO have it to transfer music to my awesome player!

Will this plugin work with my WinAmp 5.35?

I tried it, but it doesn't work. WinAmp just recognizes the player as a USB-drive, but is able to send files to it. But they are not found in the player...

Any help would be appreciated!

Thanx in advance!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...