Jump to content



Recommended Posts

  • Replies 517
  • Created
  • Last Reply

Top Posters In This Topic

Hello everybody!

So the list of volunteers for testing the next release of ml_sony is now:

dotslash => NW-S205F

markd => NWA-3000

Garth => NWA-1200

groar => NW-HD5

cautious => NW-HD5


astatine => NW-E003F

It's cool , it's quite heterogeneous!

See you soon ;)

Link to comment
Share on other sites

Sorry for the delay guy's,

here is the libtester 1


nothing much here, just press "start" button,

and see if anything fails...

if there is no problem then just post a quick word in this forum.

If something goes wrong please copy your results and send them to me as a private message to not polute the thread.

Next week release will be a usb tester... (no more keycode stuff to handle :) )

Have fun,

Link to comment
Share on other sites

Hi Otiasj,

It took my HD5 a minute or two to get the test results, but apart from that it works perfectly.


Saving custom Database




Saving Sony Database



All done!

I'm guessing the Sony database saving is meant to fail because i'm using the old ml_sony db!!?

Great work, really looking forward to the beta!

Btw anyone that gets a libusb0 error you will need to download and install http://sourceforge.net/projects/libusb-win32


Link to comment
Share on other sites

Hello everyone,

There is more problems that I though there would be,

I will release libtester 2 with an error analyser. (Probably around monday)

Cautious : Yes thank you for the link to libusb I completly forgot about that.

Keep sending me your reports please!

Thank you all for the help

Link to comment
Share on other sites

I'm not sure what I'm supposed to do. I installed libusb and put the libtester and the other two files on my device, ran LibTester.exe and I get an error saying "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem." I also tried putting it in OMGAUDIO and somewhere on my local drive with the same result. What am I doing wrong?

Link to comment
Share on other sites

I've tried it and I get a fatal .NET application error - "The application failed to initialize properly". I have Windows XP SP1 and version 1.1 of the .NET framework. I also have libusb installed. All I did was extract it to a local drive, plugged in my walkman and tried to run libtester.exe. I get the message above. Any suggestions?

Link to comment
Share on other sites


I don't understand this problem :(

When you have that problem could send me the 04CNTINF.DAT file when it's still small,

Also please send me the log files in c:\log.txt

Garth what do you mean you replace the folder?

What this program is actually suppose to do :

-find an OMGAUDIO directory,

-then scan every OMA file you have in it.

-read all the ID3 tags,

-try to read the playlist,

-Create a database in my own format to avoid doing that everytime,

-Try to write the database again in sony format

-send a usb request to get your keycode

-save everything in the log directory you created. (nothing is modified on your device)

Thank you!

Link to comment
Share on other sites

Hey Otiasj thanks for the support!

I've uploaded a .zip file that contains both log1.txt and log2.txt as well as the 04CNTINF.DAT that was created. I killed the process of libtester2 as soon as I could to keep the file from growing too large. Even doing that the file was already 140MB, although it compressed down to around 600KB when zipped. You can download the .zip here.

Thanks for looking into this and for you much appreciated continued development on ML_SONY! If you're still looking for beta testers I'm more than willing to help. I own an NW-A1000.

Edited by ltmayonnaise
Link to comment
Share on other sites

Hello everyone!

Yes I got several test results :-)

Thank you all for sending them,

thanks to that, I was able to find the problem

Another good news,

Someone is joining the development and he will release a corrected version of ml_sony

compatible with winamp 5.35 very soon.

Probably no new features yet, but we will all be able to update our winamp :)

Thank you all for the support and the testing!

Link to comment
Share on other sites

Oh marvelous !!

Hi Otias. very nice if you've been able to find the pb! for your question

I mean that i have replace my folder created with your plugin by the folder which was there when I bought my mp3 and with this one the libtest finished successfully contrary to your folder like the others pb.

Soo well , It 's encouraging for the next release :P !

Deeply with you! ;)



ps: I wrote you on your mail yesterday as well..

Link to comment
Share on other sites

Guest buggy

Okay, confirmed bug, tested and repeatable.

If a MP3 doesn't have an album tagged for it then it will crash ML_SONY when it's dragged over to the device. Filling in the album tag fixes this behaviour.

Hope that's of some use.

Edited by buggy
Link to comment
Share on other sites

otiasj, I'm using your piece of software with a portable version of Winamp and I can tell I didn't encounter any problem so far with WA 5.1 or 5.2 (of course, when I first tried to use more recent releases, I had to face some crashes, but I only have myself to blame).

I hope you will make some minor tweaks to ml_sony in the future so that we can use it as a standalone application, which would make using it easier (like SWEx does it quite perfectly, in my opinion) but, so far, I can only thank you for your excellent job.

Merci beaucoup de sacrifier de ton temps libre pour nous. :)

Edited by kimura
Link to comment
Share on other sites

  • 2 weeks later...

Guys, I'm probably doing something silly, but I'm having a problem using ml_sony with my nwa3000.

Winamp 5.33

Windows xp


I have followed the instructions : New database - OMGAUDIO folder + dat and text file.

My issue is, when I send an mp3 to the device I get the usual " transfering 1 file" etc, but the file never arrives on the device. In the media library the entry with the "m" next to it just disappears after I press apply.

Any ideas what I'm doing wrong.


Link to comment
Share on other sites


thanks for the quick reply.

I have read all the posts in this and many other threads, and so have tried different songs with different bit rates and different tags, all failed.

When I get home this evening I will check the log you suggested.

As an aside does anybody know why connect and/or sonic stage semms to work for some users and not others? (ie if you read reviews of the sony units you get a mixture of disgruntled and happy users)

Is it a persons expectations of the software or do they have different pc setups?

Link to comment
Share on other sites

  • 2 weeks later...

Hi all

First of all I would like to say thanks for this great plugin. I bought my NW-E015 a few days ago and found Ihad to install Sonic Stage to transfer my tracks to the player (the player was advertised as drag and drop). The only thing I am willing to say about SS is that from my experience it is essentially broken software. It refused to install the first two times I tried, and crashes every time I point it at my music collection blah blah blah I'm sure you've heard it all before!

I stumbled accross this excellent plugin, installed MP3FM and created a new database as per the instructions in this thread, and was copying tracks to my player within five minutes! I was going to take the player back, now I love it.

I may have missed something as I couldn't find any mention of the NW-E015 in the thread - if you have this player I got it to work with the latest version of the plugin, and the latest version of MP3FM, and with a blank database on the player. I just followed the instructions step by step and it worked straight away - why couldn't SS do that?

Thanks again for this excellent plugin.


Link to comment
Share on other sites


I meant to say the NW-E015 was advertised by the retailer as being drag and drop - had it not been an impulse buy I would have researched it and realised it wasn't suitable for my needs. However this plugin enables me to do exactly what I wanted in the first place - use winamp to transfer the tracks.

If you want me to test any new versions or tools on my player let me know

Link to comment
Share on other sites

Thank you ten times over! SS was a miserable waste of time. We have (2) Ipods and (2) Walkmans that are now being managed by ONE player! We are happy to be away from Itunes and SS, and are so grateful to use Winamp instead. Thanks for all the work on the plug in. One question... we have (2) walkmans installed, and it looks like Winamp recognizes them as the same device. Is there any way to differentiate between the two in Winamp? I did all the same steps for the second one as the first, and was happy to see that I am able to manage it with Winamp. My wishlist would be to have multiple user support in the plug in. Please don't get me wrong, I am incredibly grateful and amazed and I can live without it, but it sure would be nice :) Thanks again for all the hard work. Sony should seriously reconsider SS. Slow and painful. Ml_sony has my vote!

Link to comment
Share on other sites

Hi there,

First off, my compliments for this fine piece of work. It has saved me quite a bit of trouble, helping me to get back almost all of my songs from my player (A3000) after my computer decided to get rid of half of my collection. Very useful!

I read of some individuals having problems under Vista with transferring songs back to their harddrive. Perhaps a bit obvious, but just run Winamp as an administrator (rightclick-menu) and you'll have no problem with UAC denying Winamp write-acces to your harddrive.

If I may add one small point to your to-do list, I'd take a look at the following (rather small) problem. When you transfer back songs with song/album/artist names containing things like "?", ":" and "/", Windows apparently isn't able to save them to your harddrive. Think it's easily done to automatically convert these filenames to something without these symbols? By just removing them, or replacing them with underscores for example?

Good luck, and thanks for all the effort!

Link to comment
Share on other sites

I'm facing following issue:

When I'm looking for artists starting with "T" the player navigates to "The Buzzhorn". Before "The Buzzhorn" there is "Butthole Surfers" in the list, "Cabala" follows. When I move cursor to "Butthole Surfers" the letter above list changes from "T" to "B", when I move forward to "Cabala" it changes to "C".

The cause is obvious IMO, I just don't know whether this behaviour has been reported already or not. (If it was then no reply is needed.)

Have a nice day

Link to comment
Share on other sites


I'm a bloody newbie. Received an NW-003F as a gift, like everyone else I found that Sony's software was crap, discovered ml_sony and Winamp. Downloaded, followed Read_me ( I hope ) to backup the OMGAUDIO, create blnak files, found and loaded MP3FM, put the DLL in the right place and ran WinAmp. Whew.

From what I read here now, the current Winamp 5.35 doesn't work with the current ml_sony. I select songs from playlist, select 'Send to: E: Sony Walkman', and nothing happens.

If I haven't made any stupid mistakes so far, I'm not sure what to do at this point: wait for ml_sony upgrade, somehow find an old version of WinAmp (don't see a way to get an older version on their site), or does someone have a workaround?

thanks, everyone....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...