Jump to content
Sony Insider Forums

Recommended Posts

  • Replies 63
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

HAHAHAHHA!!!!!!!!!!!! Nice one Azureal. Surprisingly she is the only artist that I can listen to from that genre. I'm somewhat of a nerd/math-geek, and I have always admired and respected her as a pro

Posted Images

2 hours ago, sfbp said:

Oh, that i can guess. "Transfer count"?

"Transfer count" is only held in the database MtData.mdb in table t_object in column 131. If you use Microsoft Access and update that number into a fake number you see that fake number as "No. of times transferred" when you show the properties of the musicfile in SS.

Link to post
Share on other sites

Fair enough. So writing some security related info in the file. Maybe updating the database with time of last access and touching the file to make them match.

But think about it: for files to be checked in and checked out, doesn't the actual physical copy of the file need to be altered? (admittedly we know that for NetMD they never actually copied the file back, but maybe in their original scheme they had to allow for it). And I don't know the basis for your use of the key word "ONLY". If you didn't alter the file and db to match then someone can "check in" a copy of a copy and defeat the DRM completely.

All the people whose files suddenly became unplayable on a system information change now make sense.

Sonic Stage updates the actual files, not just the database. What a horrible mess, but it explains why I have had to remove files from SS and re-add them, even when nothing should have happened to them.

Link to post
Share on other sites
26 minutes ago, sfbp said:

Sonic Stage updates the actual files, not just the database. What a horrible mess, but it explains why I have had to remove files from SS and re-add them, even when nothing should have happened to them.

I have never seen that SS updated an actual file, only when in the advanced settings "Rename music files" is checked. My actual files are mp3 and wma lossless, when SS updates a file I should see that in MediaMonkey because I often check if there are unsynchronized files.

Link to post
Share on other sites
  • 2 weeks later...

I see there has been some buzz about this issue and I thank you all SO VERY VERY MUCH for your time. As of now, I have not read any of it yet because I figured it out. This is how....its really stupid and doesn't make sense but it worked.


I went back to an old windows XP machine and installed SS 3.4. The drag and drop worked. I updated it to SS 4.3 and it worked yet again. I had to do a factory reset on my win 10 machine anyway so I figured that I would try the 4.3 D &D after the clean install. I factory restored my laptop back to Win 8.1 and did a "upgrade-type" install of windows 10. (I previously installed windows 10 from a clean image and installed the firmware and drivers myself, but I'm pretty savvy with that kinda junk...so I don't think that would have affected the SS 4.3 program or cause the D & D issue).  After the Win 10 upgrade, I installed SS 4.3 Ult from this site and guess what? Still no drag and drop! :-(


Next I planned to install 3.4 to see if it worked like on XP. After I uninstalled 4.3 Ultimate that I got from the downloads section of this site, I wiped any other SS related file that remained and found an old copy of SS I made years ago on a DVD. I truthfully thought that I had saved 3.4 onto the disc, so I popped it on and ran the install. When it was complete I started the program, and selected the option to scan my computer for music files.

While the scan was underway I realized that I had accidentally installed 4.3 again by mistake!! OH NO!!


I tried to click out of it but it, but the scan process froze the program and it didn't respond. I ended the process in task manager. Next is the miracle. I have no clue why i even did this, but something was telling me to try.

I restarted my PC and re-opened SS 4.3 just for the hell of it.

Even though the music search was incomplete and not fully executed, it didn't auto prompt me again to do the search.  


Guess what???? DRAG AND DROP WORKS!!!!!!!!!!!!!!!!!!!!!!!!

I'm thinking that the program was "tricked" into believing that it had completed the performed auto search of my entire for music, and found nothing. I guess that a box was ticked in the program to perhaps ran a macro alteration of the program or something similar, which enabled or unlocked the D &D feature. Maybe it allowed this because the software had a feature that allowed the drag an drop, but perhaps only if a scan was done and concluded that there were no audio files on my computer at all. Maybe it is programmed to allow this because each time you loaded music onto the computer or as you downloaded some audio onto the PC, it enabled D & D to make the addition of music to the library a little more user friendly.

What do you guys make of this Steven and Kalkie? Sound plausible??

Link to post
Share on other sites

Maybe you tried drag and drop musicfiles while SS was still searching your drives for musicfiles to import in the database, I know that in that case you get the "non smoking" circle as you called it. After completing the search you can use the drag and drop method but not during the search.

Link to post
Share on other sites

Thanks so much for all the "discoveries" you guys stumbled across while investigating this problem. I'm kinda glad it happened now that I fixed it. That prob revealed things that I was unaware of, and answered so many questions regarding file problems and SS errors. This issue seems to have helped all of us long-term. When Steven was reffering to the actual file changing, I believe he was talking about the oma files themselves in the SS packages directory. Meaning those files that SS ripped from CD, or were converted using SS after a folder import. Any change in the actual SS userinterface would only alter and update that individual file in SS Packages. The original audio source file that was imported into SS remains unchanged. That explains why you had to delete the track and info from SS..and reimport the source file when you came across your directory error.


I'm certain you already know this.....but this is for all the noobs out there that read this...lol!

Link to post
Share on other sites

No Kalkie I wasn't. It had long since finished searching months and months ago at the time of install. This problem was static for months. I just now got it likely by tricking SS into thinking it had searched all and found nothing. A week ago,the week before that, and the month before that, I could not drag and drop. I'm sure the folder search was completed by then...lol!!!

The reason I use the D & D is because I hate ticking all those check boxes and navigating my whole file system to locate a folder with the songs that I want in it. Also if you want to import a specific folder, you have to tediously UNCHECK EACH AND EVERY parent folder that is in the C drive besides the one you want. That's ridiculous. With the "import" method you can not select multiple individual files. If I had a bunch of different music in one folder, I had to import the whole folder, or choose "import music file" and import them one at a time. For example: If I only want 10 songs in a crowded folder, I have always held cntrl, selected all the tracks I wanted, then drag and drop them. The alternative way that you guys use would require me to select the "import music files" option 10 times for 10 tracks. Or I would have to scan the folder and import the 5000 loose songs in my music folder, then delete the other 4,990 files. I know I can just make a new folder with the tracks I want and tell SS to scan it,  but thats too much work to have to do every time I wanna import and make a playlist.  If I scanned my entire library the files would be all over the place in SS....that's why I load them in an "as needed" basis. So for me..... D&D is SO much more efficient!!!!

Does it make sense now that you understand why I was getting so flustered? XD!!!

Link to post
Share on other sites
  • 1 month later...
On 21/08/2015 at 10:28 PM, sfbp said:

0. Turn off driver signing (F8 on boot)

1. unzip them to somewhere (NOT THE DESKTOP)

2. plug in your netMD machine

3. Look in devmgr for the yellow exclam

4. Click update drivers

5. Select the drivers you just downloaded

6. Ignore messages about unsigned drivers

Hooray!! Thanks for this.

Just got around to using SS43 on my Win10x64 system.

HiMDs work well, but the NetMD driver failed cos of missing hash error message.

Followed the above instructions and it now all works. Wonderful stuff.

See also:

Google: how to turn off driver signature enforcement on windows 10.

thanks sfbp,


Link to post
Share on other sites
  • 2 months later...

Hi -I have this error upon starting SS4.3 (Windows 10)

(in a dialog box)

'The selected music file cannot be played back because the system information has been changed.

Click OK to automatically close SonicStage and open the SonicStage System Information Restore Tool'

I do this and can then run SS after a couple of other dialog boxes, but I have to go through this procedure every time. Also, if I try to import a CD from my D drive to SS, I get the error message 'SonicStage has stopped working' referred to earlier in this thread and SS closes. If, however, I import a CD into iTunes and then convert/import these files into SS, I can transfer to my NetMD (NZ-510) OK - so I can get SS to sort of work, albeit a bit circuitously - any suggestions as to what I might be able to do about these errors would be most gratefully received!

Link to post
Share on other sites
  • 1 year later...

The driver is non-Windows-release specific. You need the 32-bit or the 64-bit version depending on your Windows system. Both are here on the site. In addition you will have to disable Windows checking signing (certification) of the driver for long enough to install it (and then can be turned back on again).

Good luck

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...