Jump to content

MZ-N707 won'[t power on. Looks like there's been some battery leakage in past...

Rate this topic


Recommended Posts

I bought an MZ-N707 off ebay a while back, it worked for a while but then one day didn't work. I was looking at the battery terminals and they looked a bit green - so I took the casing off, and sure enough the positive terminal on the battery compartment is corroded, along with some brown marks on the PCB around the side of that. One other thing is that it already had the MZ-N909 'hack' on.

When I put in a battery or put in a disc, the display does go a bit dark, but nothing else happens - and then it powers down, just like if you didn't put in a disc into the player but pressed a button. There's no motor noise - just the display going a bit darker.

I have cleaned the contacts on the battery terminal but beyond that haven't done anything.. Is it rescuable?

Link to comment
Share on other sites

Time for a complete adjustment. Don't do a 911 reset, Start by doing an adjustment of the values on the bottom  right of page 19. To get into service mode you will likely have to solder the TP as described (method 1), but it's possible you can use the remote (method 3). Since the display is dead you will need a remote to observe the output of your work (instead of the built in screen).

You probably want to do some basic checks with 3V power supply and so on. You do NOT need a regulated power supply, just the regular one from Sony, as long as it is working. At some point you may want to check everything starts working - even if the screen suddenly comes on, by all means finish the cycle of adjustment values.

IF none of the values were roughtly correct as you did this adjustment, I suspect someone did a 911 reset. Now you will have to go through all the regular realignment stuff. But cross that bridge when you have to :)

Link to comment
Share on other sites

OK - here's the thing. I've had the 707 sitting on the charger stand since I posted this, and today I picked it up and it works.

What can I do to make sure it doesn't recur? If it works after a few days of sitting on the charging stand what could be the symptoms? (I happened to have an Eneloop in there, and it was charged)

Link to comment
Share on other sites

Generally speaking the stand chargers don't work all that well. You may have gotten lucky. I would have tried running the device directly off the 3V jack form the power supply before getting into all the above discussion. You cleaned the battery terminals, and then the battery revived. Or something (er.... what's an Eneloop? If it's a non-chargeable, why did you put the device into the mains...?).

Glad it's working.

Link to comment
Share on other sites

Changed batteries to check, it's now doing the same thing again :(


I'm going to leave it until... well, next Wednesday I guess :mellow:


I did actually try running it directly from the jack on Sunday, it didn't appear to make any difference.


You don't know what an Eneloop is?!?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...