Jump to content

Sonic Stage Ultimate and Windows 7 install failure help


Recommended Posts

No mater what I try I cant get Sonic Stage Ultimate 4.3 to install....the files install ok but as the program runs, uninstalls old versions etc it then terminates with error code 2041


I have searched and searched and searched but I still cant get Sonic Stage or Net MD to run on my windows 7 (32 bit) computer.

I would be grateful for help to solve this.


Many thanks,




PS I have deleted all sonic stage programs and net md in the control panel, then the registry keys and then run CCleaner registry checker then re-booted. Then tried to re install Sonic Stage ultimate but still no joy?!?!!

Link to comment
Share on other sites

It's not unusual for the install to fail partway through. You should simply retry right over the top of what was there already.

I strongly recommend disconnecting any NetMD devices while the install is going on.

I also recommend you follow the steps outlined here to get rid of the 32-bit NetMD drivers. You also need to install the 64-bit driver at some point, but that can wait for the moment, as long as you don't try to connect a NetMD unit (I'm assuming that you like most people are running 64-bit Windows 7).

Also it's highly likely you've messed up the Jet (Microsoft Access) database somehow. Did you copy some stuff from another machine onto the new one? In which case it will be shot to heck unless you did it the proper way (with Sonic Stage Backup followed by Sonic Stage Restore on the new machine). Probably you need to clean off everything in C:\Program Files (x86)\Common Files\Sony Shared, especially the AVlib folder. If you have more than THREE folders in Sony Shared, stop for a moment and figure out what other Sony software is installed, and perhaps uninstall it for now. If not, go ahead and delete the lot. Now you need to get rid of all of the data in C:\Users\All Users\Sony Corporation\SonicStage.

Then reboot.

Finally, turn OFF automatic updates, and run the install as a user with administrator privileges. No idea what happens if you're on Windows Home Premium.

Link to comment
Share on other sites

Really? Then everything I said is true EXCEPT you should not have to do anything other than run the install.


a. if you have an RH1 and also some other units, install the 32-bit driver from our downloads section (after following the directions I referred to). Otherwise you will have horrendous slowdowns and likely wear out your RH1, as per the previous thread recently

b. make sure you get rid of the Connect Store URL (which will happen if you ran the Ultimate install from our downloads section). There are TWO Ultimates here - Microsoft's (edition of Windows) and Sonic Stage (ours).

Still do all the rest I said, though. I'm surprised anyone is running 32-bit Windows, as I haven't seen an application that couldn't run correctly with some combination of settings in 64-bit Windows. This includes Sonic Stage. If you tried to install SimpleBurner, that might get you into a whole heap of trouble because the incompatibility there may well be to do with the version of Windows, not the 32- or 64-ness of that version.

Link to comment
Share on other sites

Corona - Turn off Windows Update and try again. I'm thinking something is happening at 3am (or whenever Update runs automatically).

 But it may be simpler than that. You don't give us enough details:

a. What version of Windows 7 (pro or home)?

b. Are you logged in as Administrator, with UAC and/or DEP turned off?

c. What exactly were you doing when it crashed?

d. What error message did you get?

Anyway, strong recommendation NOT to use the default location for user data, as the path may become too long if the title of albums is long eg

C:\Users\My very long user name\my documents\<blah..... blah>\SonicStage\Packages\imported sound|<very long album name indeed>\<even longer track name>.OMA

So suggest you create a folder called C:\Sonicstage\imported sound\, and point the storage for uploads from the HiMD at this location. Make sure that your users (that you run SS under) has Full Control Access to it. If you're running Home Premium, you may still have a problem, and you MUST run from a "Power User" or member of Administrators.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...