Jump to content

Decks (JE640 & JE780) does not wake up after belt loading replacement.

Rate this topic


Recommended Posts

Dear Expert,

I'm looking for help for two decks (JE640 & JE780) facing the same issue : 

I've opened them and dismanteled the loading mechanism to change the loading belt (drive wasn't ejecting disk but was working fine before repair work). I've not touched anything else and both decks do not wake up. The light "standby" is red but the button power on doesn't do anything. 

I've already completed successfull belt replacement on other decks (JE770) and do not understand why those one are still asleep.

Anyone has an idea ?



Link to comment
Share on other sites

I trust you unplugged from the mains whilst doing the belt replacement :)

Try unplugging from the mains (again?), and then entering service mode (plug in whilst holding in AMS knob AND stop button). Does it now say "Check"???

Press REPEAT button. It should fall out of test mode, and probably will say "INITIALIZE" if I recall correctly.

PS if display is blank that may be simply because you forgot to reconnect it. But the RED standby light should go out when you turn on, so that's probably not it.

Link to comment
Share on other sites

If both drives show the same symptom, then something common happened to them:

- as punkrockaddict pointed it out above: ribbon cables plugged in the wrong way or improperly seated (most probable reason)

- reassembling the drives was not proper (i.e., loading mechanism or laser head in wrong position or stuck, or else), and when the drive sends the error message to the main chip, that will not allow the unit to wake up from standby

- in worst case (and hopefully not), both units got an ESD shock. These are very sensitive circuitries inside, and some safety measures must be taken before attempting any repair, or touching anything inside.

Bringing up the deck in service mode as Stephen suggested can check whether or not the device is alive. If service menu does not come up, you may want to try at least the display test (I had few units, that "pretented" to be completely dead, but properly performed the display test), plugging the unit in while pressing AMS knob and REC button simultaneously. If the display test comes up, you can also test all buttons on the front panel, i.e., whether or not the STANDBY (power on) button responds.

Link to comment
Share on other sites

guys, you rules ! 

Indeed, I powered them off just by unplugging the cord before servicing ...

The test mode with AMS + STOP worked fine. Display on, all button working but unfortunatly the repeat button did not work. 

I did check the ribbon cable a million time even before posting this thread. No better luck.

However ! I remembered showing to my kids how the motor was turning and moving the laser head from right to left .... Moving the head back in park position simply solved the problem on both drives ... 

Two conclusions :

- NGY was right.

- Never works with your kids arround ;)


Thanks you all for this success.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...