Jump to content

illogical and failed operations

Rate this topic


Recommended Posts

Home decks button's failure to respond.

 Really odd symptoms and seems that three decks failed at the same time. What I am perceiving is that there is a logic problem somewhere and this might be caused by a power failure the week before. So my explanation could be a bit long winded, yet I really need some help. Or pointers in the right direction. Like how to reset them or do the self diagnostics.

Took a picture of my work station area. I have two mds 940's and one 930 in the stack. I am utilizing most all of the audio hook ups with each one to interface with the rest of the gear. Power supply is reliable but not governed by any kind of serge protector. The decks themselves are plugged into power strips along with other gear. The three units in this location seem to be the only units affected by this "bug" I just came up with. I have not turned on any mini disc here for a few weeks and it was five days ago, we had a power outage. That is the only thing I can think of that may coincide. I am fully aware how these things operate and what happens when the power goes out. After power is restored, the units turn on. Typically you are going to see the readout, no disc. Then after a preset time each unit will go into a scrolling sony MD sort of an advertisement. They will stay that way until you shut them off again.

This power outage was peculiar in that the power went off four times consecutively for short periods. the fifth time it was out until the next morning. I was working on the computer in the other end of the house. I have not used the MD's until  today and now I am experiencing some malfunctions.

It seems as if the buttons on the front of these are unresponsive. The two knobs do work when turning them, but the push button does not activate anything. 

Eject, power, time, display... all of them fail. If you power off with the power strip, then on again and there is a disc inside it will begin to record on it. You can not shut it off. No buttons work. 

My 930 is the main utility and is controlled with a keyboard or the buttons on the face. I thought it just gave up the ghost, but when trying to operate the 940's, I found they had similar problems of failure and illogical operation too. On the 930, I tried titling and it was very erratic. Out of control when it does input something, but generally unresponsive. Adding letters on it's own, mostly "s". If you repeatedly press eject, or other letters, I have finally had that work. (930 only)

So this time when the power went off, these three decks were not automatically on when the power was restored. Due to the nature of three acting strange at the same time, I suspect the power some how did this. However, there are two other 930's in a different room and a 920 in the garage that have not suffered any oddities. There are E-12's that show no signs. It is just these three in that room.

Sorry for the long story, but I hope some one has a clue. Ever heard of this type of malfunction? These have been bullet proof other than this odd failure. No other items in this location show ill effects, (tascam pro CD recorder, yamaha hard disc cd recorder) I did not try the sony cassette), just the MD's in this station.








Link to comment
Share on other sites

Can you go into service mode on each one and then exit to cause the deck to "Initialise".

The only other option is, I know internally there is a microprocessor reset link - however this never changed anything on any of my decks when I tried it! Probably not worth opening up yet, but if you exhaust all other external attempts, may be a last resort. On some desks I believe this is a soldered link. On the "higher" decks I have like E10, E12 it's a removable "handbag" link.

Link to comment
Share on other sites

34 minutes ago, me me said:

measure the power coming out of the outlets in the room with a DMM

Don't do this. It's unlikely to show you anything useful and potentially extremely dangerous unless you have a genuinely decent Class IV DMM, like one from Fluke and know how to use it safely with high energy power sources.

Internal power supplies are regulated DC so unless the mains supply to your house is seriously out of spec (in which case I'd expect your DNO to be well aware) then the internal rails are likely to be fine. Also these decks use transformer-based (rather than SMPSU) supplies so I'd think it unlikely that their PSUs have all failed - unless you've had some local lightning strikes in which case I'd expect most of your household appliances to be dead and smoking.


Link to comment
Share on other sites

7 minutes ago, 2many said:

“Service mode”...

how do you initiate a service mode?

Depends on the deck - you'll need to pull the service manual to find out. It tends to involve pressing 2 or 3 buttons at the same time as plugging in (with the mains cord) the deck - plus standing on your head and holding your tongue at the appropriate jaunty angle (I kid you not!).

7 minutes ago, 2many said:

Isn't there a self diagnostic that can give an error code?

Yes, but this is codes like C13 that are documented in the user manual (that's what Sony mean when they put "Self Diagnosis" stickers on stuff). (I'm not aware of any "super user" diagnostics codes beyond going through a knowledgeable service sequence, taking measurements with lab equipment and comparing to information the deck displays.)

Link to comment
Share on other sites

This is Service Mode entry for the 440. The 940 is the same product line so is probably the same.

DONT go into the [Service] menu and dick with any settings.

1. While pressing the AMS knob and [STOP] button, connect the power plug to the outlet, and release the AMS knob and [STOP] button.
When the test mode is set, “[Check]” will be displayed.
2. Rotate the AMS knob and when “[Service]” is displayed, press the YES button.
3. Rotate the AMS knob and display “Err Display”.
4. Pressing the YES button sets the error history mode and displays “op rec tm”.
5. Select the contents to be displayed or executed using the AMS knob.
6. Pressing the AMS knob will display or execute the contents selected.
7. Pressing the AMS knob another time returns to step 4.
8. Pressing the MENU/NO button displays “Err Display” and exits the error history mode.
9. To exit the test mode, press the REPEAT button. The unit sets into the STANDBY state, the disc is ejected, and the test mode ends.

Link to comment
Share on other sites

OK, end of the day at the end of my wits! This all does not make sense. Ya don't just have 3 MD's go down on the same day. They has to be a factor. Theorize with me if you will...

 I have spent much of the day MD related. I have been through the auto check. (slightly different between 930 and 940) basically I was careful to avoid altering any values. It seemed that doing so cured my problem, but wait, I take the decks back to the editing suite and they are doing again with out consistency and with out any one unit being the exact same difficulty in operation. The 930 seemed cured partly, but not trustworthy to execute a function upon pushing a button. Discs refusing to eject after 30 pushes on the keyboard or unit, then suddenly popping out. Jumping to track 14 and playing less than ten seconds before returning to the start of that track. Weird stuff! Trying to record every chance they get.

So, I reserved that I need service. I got two units off the shelf, one out of the bedroom rig and replaced all three. Tested first. Like new 930, known working 930 and a 940 I put a belt in recently. working units. I install them all and rehook everything. They are all messing up. Same kind of malfunctions. It's like some fairy sprinkled some anti MD dust in that room!

I try the auto check trick in that room and to no avail. So now I am in the computer room where I did the initial auto checks and I go through the process again. 940 A, I write down the last ten codes. 940 B the same, write down the error codes and back out of the auto check.

 Deck A has no disc in it and when test mode ends the deck initializes...That is a good sign I have witnessed before! stick a disc in and all is normal!

Deck Bhas a disc stuck in it so when the check was over it just went into the on position showing the name and time as usual. And the disc plays, all functions are proper.

 With that being done, with three new working units being installed then failing too, Gotta be fairy dust in the room... I have a ton of components in there for editing and for band practice and recording. I've had a lisenced electritian bring in power for that room. The rack mount stuff plugs to rack mount power conditioners. But the stereo stuff generally runs off of power strips. 

I am not so good with a multimeter and have not checked that. I did try auto check using an extension cord coming from a dedicated known good circuit elsewhere with no magic result. 


My theory as we stand here tonight is... THE POWER STRIPS They must be causing this some how. They are inexpensive power strips. My observations remember was that when the power came back on, and I went to check, the three decks did not need to be shut off. They were off. they should be on after the power is restored. I have had them on uknowingly for days after an outing. Anyway, having the power flicker off, come back on for a minute, shut back off again four times might be the factor. Damaged the power strips? The logic in the MD's must be the only component that is suseptible to MD fairy dust. 

I am sitting next to two 940 decks that work normal, but two hours ago were malfunctioning. The 920 in the garage seems to work fine. The two 930's in the bedroom work fine, (till I took one to the ...It's called the brownroom...) Where all this malfunction is going on. So, power outage, cheap power strips. These are the kind with an on/off switch on one end. I am thinking of going out for some higher quality options there. 

In the meantime, here are the error codes from the two 940's sitting next to me that seem like nothing ever happened. What does it all mean?

Deck A code 1-50 code 2-10 code 3-20 code 4-50 code 5-10 code 6-20 code 7-50 code 8-10 code 9-51

Deck B code 1-50 code 2-10 code 3-20 code 4-50 code 5-10 code 6-20 code 7-50 code 8-10 code 9-20        Nearly identical, though 930's are reading slightly differently.

Details of Error 

10 Loading error 

20 Time out. The beginning of PTOC cannot be read 

50 Address cannot be read although access processing is not in progress

51 Runaway due to focus NG


Thanks for listening, what do you think?


Link to comment
Share on other sites

I think your suggestion to try another power strip is a sound one (excuse the pun!).


Those error codes are fairly typical to find in a deck of a fair few years old. If you clear them, then you can see what new ones come back. But as your decks are generally in good working order I don't think they'll tell you anything of interest.

Link to comment
Share on other sites

5 hours ago, kgallen said:

I think your suggestion to try another power strip is a sound one (excuse the pun!).


Those error codes are fairly typical to find in a deck of a fair few years old. If you clear them, then you can see what new ones come back. But as your decks are generally in good working order I don't think they'll tell you anything of interest.

Right, the one thing I have not done as I pass through the auto check logs is clear the history. I merely examine the logs and move on. Careful not to make any alterations concerning operation. These decks all have been trouble free but for 940 belt issues and the logs show the code ten which I think was related to that.

More switch outs and trial runs will take place today. 

Link to comment
Share on other sites

I am getting some light in this crazy tunnel. 

 Several more attempts to get proper functionality were fruitless. Bypassing the power strips and going right off the power conditioner did not bring back the three MD's currently installed. Funny though, one previous unit which had entered the crazy zone previously, continues to work outboard of my whole stack of stuff. Almost seemed as if putting an MD in place for operation was the cause of malfunction. But no...

At the time my electrical service was upgraded to a 200 amp service, I also had an 80 amp service drawn to, and installed at the other end of the house, thus supplying service to audio equipment. I got to thinking about checking or replacing the breakers. I reset the breaker supplying power to the brownroom in the 80 amp panel, as well reset the breaker to the 80 amp sub panel at the main. 

The decks all function as normal now. What I do not know is which one was the culprit or what was wrong with it. Supplying power, yet oddly not appropriate power. The MD decks are on std-by 24/7 by sony default. Might be why they were affected because of that.But too,  I remember when the power went out those four times, coming back on almost immediately, but not with out a seemingly crackle or a "short" as it was doing so. I mean maybe a corroded surface on the contacts of the breaker that was not letting GFIC or polarity be proper? I do know that the voltage was not the issue as you can see in the following photos I will load. Photos taken prior to breaker reset. I don't know what was wrong. I just need to decide now how I want the final hook-back-up to be.

IE, MD's on a separate surge protector?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...