Jump to content

SonicStage 4.3 closes immediately after opening (no error message)

Rate this topic


Recommended Posts


First let my say thank you for all the effort which has been put into keeping netMD alive.

And I had a working setup on this very computer, Windows 10 x64 with SonicStage 4.3 and a MDS-NT1 connected permanently.

The last time I successfully recorded an MD was about 2 Months ago (April), but after trying today, SonicStage just immediately closes after loading it's UI but before showing any content of the library. Without any error message whatsoever.

I re-installed SonicStage, used the Ultimate installation from here. I removed my old database, removed the Home Registry Keys, resetted my Windows installation.

Now SonicStage sometimes shows the welcome screen with the new database wizard (See attached image). But then it closes without error message.

Anybody of you any idea what I could try next?

Thank you


DX Diag:

      Time of this report: 7/1/2020, 18:31:06
         Operating System: Windows 10 Pro 64-bit (10.0, Build 17763) (17763.rs5_release.180914-1434)
                 Language: English (Regional Setting: English)
                     BIOS: BIOS Date: 04/06/18 12:22:22 Ver: 05.0000B (type: BIOS)
                Processor: Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz (12 CPUs), ~3.3GHz
                   Memory: 32768MB RAM
      Available OS Memory: 32692MB RAM
                Page File: 31228MB used, 6582MB available
              Windows Dir: C:\WINDOWS
          DirectX Version: DirectX 12
      DX Setup Parameters: Not found
         User DPI Setting: 96 DPI (100 percent)
       System DPI Setting: 96 DPI (100 percent)
          DWM DPI Scaling: Disabled
                 Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
           DxDiag Version: 10.00.17763.0001 64bit Unicode


Link to comment
Share on other sites

  • 2 weeks later...

Thanks for the suggestions, but after re-trying any of the applicable ones, it still doesn't work.

 - Compatibility mode with XP just starts a DB conversion tool, every time the program is launched. In other modes, same behavior as without.
 - I never get any error messages or error codes, the program window just closes after a few seconds or immediately.

Link to comment
Share on other sites

Ouch! If it was working before, it sounds like Windows update did this. Very sorry and if it turns out to be so, thanks for the warning.

I would

a. remove any NetMD completely from the system (unplug)
b. remove all NetMD drivers (the procedure is complex but it doesn't matter if your device is not plugged in)
c. run the restore program (SS install just put it on your menu) and see if that does anything.

I really really hope you listened to all of us here and ran the File Conversion Tool every time you send any music to the PC. But with NT1 maybe not an issue.

Link to comment
Share on other sites

Thanks again for these suggestions.

I tried

a. & b. re-connected NetMD to uninstall the drivers, then disconnect NetMD again and try another driver delete with pnputil.
c. was unable to find th restore program, so I tried uninstalling and re-installing SS Ultimate incl. the reboots.

still closes directly. Does SS or Windows generate a log-file of what is happening or is there some other way to try to get a glimpse to why it may crash?

No worries, I only ever moved music from PC to netMD. So no tracks are trapped in OpenMG.

Link to comment
Share on other sites

Interesting question: why are you named ZueriHB (sounds like a famous railway station in your native tongue - just guessing)? I ask because I once stayed in the delightful village of Uhwiesen and we *walked* on foot to the Rheinfall mostly on ZH land (they even had little brush-clearers being operated by workmen, clearly labelled and belonging to the Kanton).

I would get rid of ALL NetMD drivers.

The complicated procedure is laid out somewhere but you are knowledgeable, patient and persistent, so I will give a quick sketch.

1. Enable hidden devices (2 System Environment settings from "Advanced" under System properties of the computer, devmgr_show_nonpresent_devices, and devmgr_show_details, both set to 1)
1a. make sure ALL NetMD drivers are uninstalled, even the hidden ones.
2. Look in C:\windows\inf (hidden directory) for all oem<nn>.inf (nn usually somewhere between 50 and 100 sometimes on very complicated systems can be over 100 so then <nnn>). Delete anything where the first line or two has the text "NetMD" (maybe "Net MD" I'm too lazy to look at this moment, same as one of the drivers you've installed). Usually it is one of the last few to be added.
3. Reboot
4. When NetMD driver (if it does) comes up remember to install the driver package I put together in the downloads section here (it's unsigned so you will have to put W10 in a special mode in order to allow you to install unsigned driver - I'm sure you are capable of that!) for NETMD760

But hopefully at least SS won't crash.

If that doesn't work, my personal preference (anyway) is to move the SS library to somewhere else (make a junction link, copy the files there) other than the default which is subject to all sorts of permission and ownership problems; and make the "somewhere else" (eg C:\sonicstagelib) have permissions readable by all. It may be as simple as the crash is from accessing the library in your default location (aha! did you start using a different login recently?).

Good luck


Link to comment
Share on other sites

Thank you.

Hmmm.. Uhwiesen, I heard of that little village (I'm in the neighboring town).

No Devices called netMD were left over, but I found 3 or 4 oem<nn>.infs with netMD, one was oem1.inf (!).

After a reboot, I tried SS directly, didn't work, still the same symptoms. I didn't connect my netMD (yet).

I made a copy of my library before resetting Windows and SS. Currently I'm trying the unsubtle apporach of trying to setup a VM with USB passtrough.

Link to comment
Share on other sites

Yes, that is why I commented given your profile says Schaffhausen :)

Have you tried any other applications that depend on the OMG libraries (eg playing OMA files with Windows Media Player)?

I have a similar situation with Simple Burner running in Windows 7 (main windows disappears with no error message). I could only get SB to work in XP virtual PC.

Sadly I think VMs come with their own complications.

Sonic Stage works perfectly on all versions of Windows, just the NetMD support needs the right driver for 64 bits.

Link to comment
Share on other sites

Event Viewer *head -> desk* *palm -> head*.

Have a type 1000 and 1001 error, had to piece together that px.dll is indeed missing and that is why the software was crashing.

I'm now again able to browse my collection. Now to re-install the x64 netMD drivers. *fingers crossed*.



Thank you so much for your support!


Link to comment
Share on other sites

That's weird, my post about the 1000 or 1001 error disappeared. I can't even remember what I was expecting you to find, that conclusion was so many problems ago - I had a rather difficult afternoon yesterday. Well done indeed  to figure out what was missing - very strange that there was no other error.

Anyhow you can buy me a beer the next time I visit my favourite tourist destination.

Link to comment
Share on other sites

Your post is at the top now, I voted it up as the answer that fixed my problem.

One error said that something was missing and thus it crashed. The other error specified this dll, but not what the problem was ^^.

Let my know when your in the vicinity. Maybe in 2021 ^^;;

Link to comment
Share on other sites

Great, another of life's mysteries explained :) (that is, the disappearing post)

I would really hope to make it to Europe again next year. Cross fingers. Honest, I cannot remember the contorted chain of reasoning which led me to expect 1000 or 1001. Never seen this before.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...