• Version Version 1.4
  • 10,941 downloads

These are the drivers you will need to get NetMD devices to work with 64-bit Windows 7 and Vista. For Hi-MD devices in Hi-MD mode, no driver is needed, however for NetMD mode you will still need this. Compatible models: NetMD: NW-E7/E10 MZ-N1 LAM-1 MDS-JB980 MZ-N505 MZ-S1 MZ-N707 MZ-N10 MZ-N910 MZ-NF810/N710 MZ-NF610/N510 MZ-NE410 MZ-NE910/NE810 LAM-10 AM-NX1 MDS-S500