Jump to content
Sony Insider Forums

MZ-N910 Connection Issues

Rate this topic

Recommended Posts

I was hoping someone could offer some advice please?
I recently dug out my MZ-910 and box of Minidiscs and assumed it would be quite easy to get it hooked up to my PC so I could use it again (just having files on my phone and ipod is so boring) but I have been defeated.
I can't get my PC to recognise that it is connected.
I've tried various downloads from official to downloads from here, I've tried installing from the original disc it came with too as well as doing stuff like running in admin mode and disabling driver signing.

I've tried on my Win 10 Home pc, my Win 10 Pro laptop, Win 7 Home laptop, a Vista laptop, an XP laptop.
I also gave it a go using Virtualbox to try Win 98, Win 98SE and XP, then I tried doing the same using Hyper-V.
I've done clean installs on all but 1 of these devices and I still can't get anything else to happen besides it connects, says it's unrecognised then disconnects, then reconnects, says it's unrecognised, then disconnects......(Imagine endless loop here)

The many hours of this has led me to believe that either the MZ-910 is broken in some unseen way (It functions on it's own fine and displays PC>>MD)
or that there is something very specific about the USB that came with it. 
I've been through every USB cable I could find, including 2 grey Sony ones and none make a difference. 

Can someone help please?

Share this post

Link to post
Share on other sites

Thanks, that's what I had been doing though. I tried installing using the downloads from the Sony Support page, some from a download I got from here and also installing from the original disc that came with the device. 
It wouldn't be so bad if all my disc weren't track locked so I could erase them.

Share this post

Link to post
Share on other sites

But I bet you didn't START with the 64-bit driver. (which unfortunately you have to override Microsoft Windows' dislike of unsigned driver files - the driver itself is unchanged). The one thing that changed about most people's setup is that the OS is (usually) no longer 32-bits.

PS no need to uninstall SS. However you may want to get rid of all the 32 bit drivers (follow the instructions here)


Share this post

Link to post
Share on other sites

Thanks again for your help but I still can't get the thing working 
I went through the steps showing and removing drivers and I installed the drivers downloaded from here (NetMD Driver 64-bit Win7 or Vista pack) and the SonicStage Ultimate from here.
I've just restored my laptop to its factory state running Win 7 Home Premium, do you suggest trying those downloads again before I plug the MD in?
I thought a clean install should give me the best chance of success as there's nothing to conflict 
Thanks again

Share this post

Link to post
Share on other sites

The problem is that the SS install includes all the 32-bit drivers by default. Never mind that you don't need ANY of them (sigh - I wish I knew enough to update Avrin's careful work with the SS install to do that).

Simple things come to mind. Have you been doing with power adapter for 910? If not, maybe it's flaky connected if the battery ain't good. The "original" NetMDs could not draw power from the USB connector, so you need to have a stable source of power.

As far as erasing disks, you should be able to do a FORMAT (Initialize) even of a NetMD disk. If this fails there are two known ways to blank a disk:

a. A portable unit whose OWH is dead and will blank ANY disk the moment you try to write (even a single trackmark)

b. A pre-NetMD deck (anything with no USB connectivity should do it) will ignore the TrProtect flag when formatting disks.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now