Jump to content

Sonicstage error 00005e30 Win 7, 64-bit

Rate this topic


Recommended Posts

I myself am trying to install Sonicstage again, and as usual, have some problems with it. (every new install gives a problem on my machine, it seems.)This was the case on Win XP (various times). Win Vista, I never bothered to try, and now on Windows 7. (all my music on the mp3-player was transferd with my old Win-XP installation, several years ago) And now I,m trying to install this on Win 7.

Installation goes fine, only after installation the program cannot acces the database-files. Error code 00005e30. My experience with this program tells me that this is the MDAC-error.

So I tryed to install MDAC, but it doesn't work. Probably because MDAC only applies to x86 based systems. Now, my CPU is 32-bit compatible so I don't know if this is causing the problem.

But does anybody know what my problem can be? I downloaded the modified installer from Silvos, only to find out it doesn't work either.

Link to comment
Share on other sites

Open the Command Prompt, type the following:

regsvr32 "C:\Program Files\Common Files\Sony Shared\AVLib\SsDbMan.dll"

and press Enter.

EDIT: You may need to change the command, depending on the actual location of the SsDbMan.dll file in Windows 7.

Edited by Avrin
Link to comment
Share on other sites

Hello Avrin,

thank you for your reply so soon, only it does'nt seem to work either after SsDbMan.dll was succesfully added.

I did a uninstall and installed the latest version from sony.

De error on startup remains the same, but when I run the program in winXP (sp3) mode I get a 0004e3e error. The sonic stage information restore tool doesn't work (never worked either, even under previous installations)

Finally if I run this program in Win server mode I get an error 00005e27.

But I think the best chances for this program to work is if I could be able to fix the 00005e30 error.

Has anybody other suggestions?

Or is there another program which can succesfully transfer music to the NW-A1000 MP3 player?

Link to comment
Share on other sites

Try also registering another file:

regsvr32 "C:\Program Files\Common Files\Sony Shared\AVLib\SsAppDbMan.dll"

Again, the path may need to be changed.

Again, it doesn't work. At the moment I,m writing a batch file to load all the DLL's in regsvr32. Hope it does help.

Are there any tips to load all the files in the folder? or is the only way to write multiple lines? like:

[open notepad.exe]

regsvr32 "D:/Program Files (x86)/Common Files/Sony Shared/AVLib/SsAppDbMan.dll"

regsvr32 "D:/Program Files (x86)/Common Files/Sony Shared/AVLib/SsBeServicePS.dll"

regsvr32 "D:/Program Files (x86)/Common Files/Sony Shared/AVLib/ATL80.dll"

save it as a .bat file? and run it a a adminastrator?


[edit] this is propably not the problem, because again it doesn't work

Link to comment
Share on other sites

Common SONY files on drive D: look a bit strange. Usually they are installed to drive C:, even if you select to install SonicStage elsewhere.

Yes, It is strange and I don't know why, But I have my D:/ as boot partition.

in the past I did set up a dualboot system for windows Vista and Windows 7 RC 1.

When I bought the new windows 7 OS retail I normally installed it (on the C-partion), but with my latest reinstall the system somehow installed on the D-partition and not on the c-partition. (maybe I did't pay enough attention on chosing the right partition) But I don't think this is causing the problem. (or is sonicstage configured for a "Standard install" only?

anway, the problem has became less urgent: I have installed sonicstage on my old Win XP laptop. Less convenient, but it works.

Avrin or somebody else: Any clues on what the I could do next? at least I learned to use the option Regsvr32 and how to set up a .bat file :). So your help so far was not useless at all.

Link to comment
Share on other sites

I don't think that re-registering files will help in this situation. The problem is most probably caused by D: being the system drive and leading to non-standard system paths. I remember reading in some documentation that OpenMG/SonicStage require that the installation of the OS be as standard as possible. E.g., dual-boot systems and customized OS installations are not officially supported, etc.

Link to comment
Share on other sites

too bad. Well. At least it explains why I always have had problems with this program: I just don't like the standard config of a C: partition for windows, documents, video's, programs, pictures etc. and a big empty D: partition for everything else :scratchhead: . (a BSOD and you loose everything because it is on the same partition as the OS files, no thank you)

Link to comment
Share on other sites

As a last gasp, try cleaning up the default URL's in the registry under EMD. If you don't know what I am talking about try looking at


In fact you might take a generic sweep through the registry looking for "C:"


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...