Jump to content

Transferring Net MD recordings

Rate this topic


Recommended Posts

I have just purchased a MZ-RH1 in order to transfer my old records, that were done using an external mic and Net MD device, to PC. I am looking for the best way to archive those records. I have a few questions:

1. Since all my recordings are done in standard MD mode (mostly LP4), I won't be able to use HIMDRenderer, QHiMDTransfer or any other program to transfer my records. Only SS will work, right?

2. SS allows to transcode transferred *.oma files to *.wav files and I should use this feature to get DRM-free audio files, right?

3. There is no way to losslessly transcode *.oma files to any other format without increasing file size massively, right? For example, 10 Mb *.oma produces 210 Mb *.wav file and if I compress it to *.flac I still get 78 Mb - that's almost 8 times larger file. In other words, there are no tricks to further losslessly compress and get smaller file size, right?

4. *.oma files created by SS still have DRM protection even though it lists the following info under file's Properties?

Playback restrictions: None
No. of times played: 0 times
No. of times transferred: 0 times
Remaining transfer count: Unlimited
Remaining ATRAC CD transfer count: Unlimited
Remaining audio CD transfer count: Unlimited

5. To get rid of DRM protection I asked in (4) I have to use File Conversion Tool. This will assure that no DRM protection is left within my transferred *.oma files, right?

6. If I have used SS to transfer not protected music to my Net MD device, even with MZ-RH1, I will not be able to upload it back to PC, right?

Link to comment
Share on other sites

Very good research. You are correct on all counts. Note that FCT is essential in case Windows update or System Restore nobbles the DRM keys - you should plan to run it either after every upload or on some regular basis if you don't want to risk some track becoming unplayable.

Net MD tracks transferred by USB (except if you use a Hi-MD formatted disk) TO the device are stuck. Forever. Sorry. Even the RH1 can't help you with these.The only way that might work would be to create a fake TOC and clone it, IF the recordings to NetMD were made in such a way that you did them sequentially without erasure. In this case, I would then transfer the entire 5hr 23m (LP4) track to the computer and then edit with Sound Forge 9 (or 10). Other than that, buy a deck and play back at x1, recording the optical output either to (hi)MD or direct to PC sound card.

LP4 (and LP2) tracks made by recording from analogue or digital sources at x1 (i.e. everything except USB) can be transferred, HiMD tracks made by transfer can be transferred provided they didn't have protection when they were transferred. They're essentially "just" files, and are copyable to the PC using a variety of techniques (i.e. software) not involving SS if that software balks.

So you're OK and the microphone tracks will all be fine. I strongly recommend NOT transcoding uploaded MDLP tracks. They can be played just perfectly using VLC even if the DRM is still there, They can be transcoded using ffmpeg, too. So one way is to put them on a server and play back on demand. In this case ffmpeg on the server will likely transcode to CD bit rates which can be played by anything. Something else: MDLP (LP2/3/4) are transferred to the PC bit-for-bit. SP is not (at least Sony doesn't actually give you a way, transcoding to WAV or Hi-SP 256k when it gets there).

When you transcode (assuming you don't like my recommendation), you should put into MP3 or HiMD (ATRAC3+) of at least 256kbps. There's little point in trying to convert to some lossless format like FLAC or WAV or ATRAC Advanced Lossless. You can experiment with all this using Sound Forge (which you will have to buy at a cost of no more than $50 - if you can't figure how, come back here and advice will be offered).

One final point: using SS to transcode to WAV is not a great idea because any metadata (except title) carefully typed in on MD will be lost. And don't even THINK about putting to HiMD 1411 .oma format. Sound Forge doesn't recognize that, even though it's only WAV in a wrapper.

Link to comment
Share on other sites

I have started my transfer process, but I have run into quite an unpleasant issue. By pure accident I have opened one of the transferred LP4 files in Sound Forge 11 and realized that Sound Forge could not read the end of the file, i. e. it was empty at the end, and I know for sure that there is audio data up to the last second of that particular track. To verify it, I have opened that oma file in VLC and it was playing fine from start to end. Then I have tried transcoding oma file to wav using SS, it did that, but instead of getting 60 minutes of record I got 55 minutes, so basically the last 5 minutes were chopped off. The biggest problem I see here is that SS did not report any errors while transferring track or transcoding it. So, in theory I need to check every single uploaded oma file to be sure it is not blank or otherwise damaged.
Can anyone suggest any better approach as it will be very time consuming to check hundreds of oma files manually?


Link to comment
Share on other sites

I think you have hit a glitch of some kind. FWIW I don't usually upload very large LP4 files (although I certainly have uploaded hundreds of hours of LP2 in large chunks). There exists a problem with long files where SS reports a strange % figure as it does the transfer. This corresponds to reaching the limit of the file size as a 16-bit number of clusters on the disk. This will differ depending on whether it's LP2, LP4, SP or some Hi-MD format. Note that this is NOT a real problem, just a displaying-the-data-as-it-uploads cosmetic issue.

Guessing right off the bat, I would say that somehow you hit this wrap-around in the counting precisely when there was a fragmented cluster. Is this possible? Thanks for reporting it - of course there's nothing we can do because Sony doesn't maintain Sonic Stage (and neither do we have access to its code).

The only other difference from my setup is the use of Sound Forge 11 (I use SF 9 and have briefly tried 10 which came bundled with Movie Studio Platinum). Try playing the file using VLC and BEFORE you run FCT, just to see if the bug was in the conversion (decryption) rather than in the transfer. If it plays correctly in VLC, then there may be a problem with the newest version of Sound Forge or with FCT. If not, then, as you say, Sonic Stage is messing up (I assume you tried this several times before reporting the problem).

Oh yes, one thing - always run FCT from within Sonic Stage (the Tools menu when in "Library" view). Otherwise it does weird stuff. DO NOT drag and drop files as a way of importing to SS - this causes strange problems with copied files.

Link to comment
Share on other sites

Yes, this file is one of the larger ones I have transferred. However, I have managed to successfully upload 4 hour record (LP4). And yes, it took forever to complete and estimated remaining time and percentage figures were going crazy during that process.

Yes, I have tried several times to upload that file and always got the same result. VLC can play that file fine before I run FCT and after I run it. When I transcode that oma file (before and after I run FCT) to wav using ffmpeg I get one of the two errors:

Frame decoding error!
Error while decoding stream #0:0


JS mono Sound Unit id != 3.
Frame decoding error!
Error while decoding stream #0:0.

So, based on all these finding I think that SS messes thing up and does not inform about any problem the end user.


BTW, I use FCT from within SS all the time. File size of that oma file is 28.4 MB. And I am not sure I understand your question about fragmented cluster.

Link to comment
Share on other sites

I think it's a bad disk in some way. If you really want that 5 minutes of music, you must play it back on the MD and record the result somehow. Sorry.

Added:  maybe if the file does play in VLC all the way to the end, you can use ffmpeg to transcode it.

Possibly what's happening is that you have a file which is for some reason partially encrypted (i.e. the last 5 minutes are encrypted but the rest is not, or vice versa). This would confuse SS but possibly VLC doesn't care as it is coded to different standards. Be happy if you can play the file as that should allow you to recover it.





Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...