Jump to content
Sony Insider Forums

Looking for USB_PatchWriter for MZ-N710

Rate this topic


Recommended Posts

You probably don't need it, provided you can get into the service menu with keypresses.

Problems: there are multiple versions corresponding to different roms (of course); the software may be hardwired to windows 98 (not sure but I have my suspicions). USB 1.1 at best.

I have a disk with stuff like this on, but not directly accessible for another week or so.

Link to post
Share on other sites

 

I am pretty sure it's needed, as I already reseted the NV memory as per service manual instructions, and therefore need restoration of NV content. 

The rom version I have is 1.600.

Looking forward to try out your disk..

Thaï you for help.

Link to post
Share on other sites

OK. I remember now, and have looked at the file. I have the patchwriter, BUT YOU DON"T NEED IT. It's absolutely not needed just because you took the machine apart and reset the NV RAM. It's to do with the NetMD functionality, which contains encryption keys that are derived from the master keys at Sony. The only reason you need to change them is if you got a brand new main board with uninitted NetMD leaf data.

The rest of the alignment doesn't care about this stuff. Be happy, and proceed with your alignment. Always start by setting the temperature (it's a hex number so 0x1A corresponds to 26 degrees centigrade in the room you are working). It will reset each time you enter test mode.

Link to post
Share on other sites

Thank you for the hint.

What I did so far, is reseting the NV RAM and gone through the "Manual Adjustment" up to, and including the power adjustment.

However, when I exit the test mode and restart in "normal" mode, the LCD displays "ERROR" 

So, refering to the thread quoted below, I was assuming USB_PAtchWriter was needed.

I will retry the fulll adjustment/alignement procedure to its completion, and hopefully that should resolve it then... 

 

Link to post
Share on other sites

You cannot do only a "Manual Adjustment".

You will need a blank MO disk and one prerecorded (CD not MO) disk and you will need to do the automatic servo calibration (called "overall adjustment mode"). The reason it says ERROR is nothing whatsoever to do with the USB/NetMD side of things. What's happened when you set the NV Reset, is that the byte at (I think) 2131 is the status (its documented somewhere) of that Overall Adjustment or servo calibration. There's a bit for CD, a bit for MO, and you must do the CD first, or the alignment for MO won't work. For HiMD there's one or two more bits yet to do with HiMD but those don't concern you today.

You can cheat each overall step by setting one or more bits in that byte but I guarantee you everything will be out of whack. Hopefully you (out of curiosity) bought a prerecorded MD at some point. Otherwise you're out of luck.

Sorry to be the bearer of bad news.

Link to post
Share on other sites

Ok.

I have been going through the Overall Adjustment, but stuck so far as I don't have a CD disk, (doesn't work with recorded MO... stuck on test 324...) 

I am currently waiting for a prerecorded MD to be delivered.... I'll keep you posted ;-)

 

Link to post
Share on other sites

Finally got my hands on a pre-recorded minidisc, and managed to go through the whole adjustment procedure, including the "Overall" one, and it's all ok now.

So, I confirm that you were perfectly right : no need to rewrite NV parameters, and therefore no need for USB_PatchWriter.

Thanks a lot for your help!

Link to post
Share on other sites
  • 4 years later...

Read the rest of this thread in detail. Note there is no such thing as MZ-R710, you will have an MZ-N710 which is a completely different beast from the one described in that link in your last post.

You need:

a. the service manual (start at page 25 in the NF810 service manual, I can't lay my hands on the 710 but it is the same unit minus the remote radio).
b. a prerecorded CD (any old one will do)
c. a blank 74 minute MO, preferably unopened (80 may work just fine but I think the service procedure was designed around  74)

There IS a procedure where you can trick it back into life by UNresetting the parameters, but I wouldn't recommend it unless absolutely desperate. I'm not publishing it here. If you can figure it out well enough to get it right you are half way to doing the Full Monty alignment anyway.

If and when the "servo alignment" doesn't work then you have to go back to first principles starting with the hardware and basic functionality. I am starting from the premise that someone did a "911 Reset" (curious name) that led to the situation you are now in.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...