Jump to content

MDS-E10 drive won't load disc/IIC Stop

Rate this topic


Recommended Posts

Creating a new topic for a fault discussion to avoid hijacking an existing active thread! 

So I've rescued an MDS-E10 from eBay listed as spares or repairs because of a load failure. I'd like to fix it to use at my local drama society. I already have a working MDS-E12 that might help me fix the E10. Particularly for the next show in June, it would be really beneficial to have both the E12 and the E10.

The E10 I've just received is in immaculate, pretty much "as new" condition. It's virtually perfect outside (no rack rash or even signs of being much out of the box really), and inside it's spotless. Not even any dust. In Service mode, the odo counts claim record time "Less than 1 minute" and play time "2Mins". It's possible of course that a previous owner has reset these, but given the apparent unused state of the deck I'm inclined to believe these, which would suggest the load fault has existed pretty much from new.

There is no disc stuck in the deck.

I've had the lid off and replaced the load belt. I've had a look round and the drive is immaculate - no apparent missing parts, nothing broken, no dirt, no bits of plastic rattling around in the bottom of the case

So the symptoms:

- On power on, the screen lights up (perfectly), with the MDS-E10 logo and the L/R meter -INF points lit. The drive seems to try to go through a series of initialisation attempts. The L/R -INF points go briefly off a number of times as it goes through a number of cycles. The laser sled moves cleanly, and does some hunting. The laser can be seen trying to focus. The sled ends up on the outer edge of where the disc would be and does a few cycles of end-stop bouncing. There is no disc in the machine. It's as if the machine thinks there is a disc in there.

- The drive won't load a disc. On inserting a disc (drive lid is off), it can be seen to activate the slide lock pins as expected. However it won't "grab" the disc and pull it into the machine. Having had the upper frame of the drive off to replace the belt, the rack and slider system that would carry the disk into the loaded position are clean and move freely. I'm at the point of thinking the load switch on the BD board is not operating. However this is on the "A" side of the PCB and is thus not at all accessible. However from the schematics it seems like the 4 switches on the BD board (load, limit, play, rec) are commoned to ground on one side and then go to the ribbon connector to the main board on the switched side - so in theory I could get the Fluke or a scope on there and see if these switches are operating. I haven't done this yet.

- During these initial "cycles" on occasion you can hear a motor run for a few seconds (a different one to whatever servos are moving the sled and doing the laser movement). Looking inside, I've never seen the disc motor spinning (well there isn't a disc in, so that would be ok) so the only other motor is the load motor, but since this is much deeper into an assembled drive it's harder to see.

- So after the drive has done this 3 or 4 times, it "gives up" and the screen changes to the "IIC STOP" message. However the drive does then go on to "try again".

sfbp has suggested there is a fault in the IIC control bus: 

However I think at this point I'm more hopeful as I've seen the drive go through a number of "control based" actions (sled move, laser focus) that hopefully means this isn't the case. However IIC (or I2C as I more usually know it) is a fairly simple 2-wire serial protocol, so should it really come down to this then I think I could take a look at this - I think my 'scope has an I2C protocol decode on it too. However for now I think I want to check some of the other "simpler" mechanical functions and switch sensors.

Anyway, thanks for listening thus far! If you've any ideas, please post them. I'll update with what I find. Thanks to Jim on the previous thread for posting the video on the "rear release clip" for getting easy access to the load belt. Thanks also to sfbp for posting about the IIC Stop. I'm sure we'll be having more dialogue on this one!

Given the excellent state of this deck I'm really hoping there is some daft simple problem that is stopping this deck working!





Link to comment
Share on other sites

Is the sensor that detects the presence of the disk working? I know where it is on the portables but I've never had this problem with a deck. It (the fault) could be mechanical or electrical in nature, it is easy to imagine the former, but without knowledge of the mechanism......

Link to comment
Share on other sites

15 hours ago, sfbp said:

Is the sensor that detects the presence of the disk working?

Hi Stephen,

It's this that I'm looking for. It must be some kind of switch although as yet I can't find a mechanical actuator that goes from the disc slot to any kind of switch. There are 5 switches shown on the schematic:

- S101 LIMIT-IN-SW - Not sure but I don't think this is the one.

- S102 PROTECT switch - for record defeat, detects the disc record prohibit slider position. This is the one that has the tiny white and blue pins that align with the dimples on the back of the disc when the disc is seated fully into the drive

- S103 OUT-SW - Hmmm could this be the one?

- S104 PLAY-SW

- S105 REC-SW - This and the PLAY-SW are on the other edge of the PCB. I don't think they are related to disc load.

All of these - and the loading motor - go straight out to CN102/27P which I think is one of the ribbon cables. So I should be able to probe these. It also means they are monitored and driven by the main board rather than the BD board, so I need to have a look around that PCB for likely issues.

Also I2C comes in on the same ribbon, but it only goes to an EEPROM on the BD board, which will be there to tell the main board what type of BD board it is, and probably holds the Iop/Iow settings etc for the laser.

More investigation to do... thanks!

Link to comment
Share on other sites

What's that "263" thing in the pic? Looks like a little mechanical sensor to me. Strange label "4-226-990-01 BASE (BU-A)". Sorry, as I say I've never had to mess with it. But if the spring is dodgy or the contact doesn't close when disk inserted, there's your culprit.

Link to comment
Share on other sites

10 hours ago, sfbp said:

What's that "263" thing in the pic? Looks like a little mechanical sensor to me.

It's just a small plastic end-stop/clip at the end of the laser sled.

So I took a look at the I2C on pins 21 and 22 of the 27-way ribbon. The data (SDA, pin21) looks very good. The clock (SCL, pin 22) I'm a bit undecided about. With the ribbon cable out, it's a nice clean square clock. With the ribbon in, it seems to be permanently high with some noise on it. I guess I might not have had my scope triggering properly. Certainly this bus has plenty of bursts of data on it. However from the schematics it does just look to go to the 24C08 EEPROM (non-volatile memory).

Both of the ribbon cables buzzed out ok. All three motors on the BD board had continuity (sled and spindle ~5 ohms, load motor ~12 ohms).

I had a look at some other signals on the ribbons. Noting much of note there. I couldn't see any activity on the loading motor signals (pins 26/27). I had the lid off of the drive and the motor I could hear operating on occasion was the spindle motor, not the load motor. So the drive is thinking there is a disc in there to run that motor and with the sled/laser focus activity seen. I'm a bit concerned the laser sled usually ends up bouncing against the outside end stop. It makes quite a noise so I'm a bit concerned it's being stressed a bit. Didn't see anything interesting on any of the 4 PCB switches (REC-SW, PLAY-SW, OUT-SW, LIMIT-IN-SW). I need to do some more investigation there. The "REFRECT(???)/PROTECT" switch S102 seems to buzz out ok on both its contacts.

I had the drive apart a bit more having a look around. Thoughts are that when you insert a disc you press it in slightly which moves the slider a little. This action pushes through the slider and I suspect onto one of those switches on the PCB. I haven't proven this yet but I can't see another mechanism for disc insert detect. I've not had the guts yet to disassemble the BD PCB away from the drive chassis to be able to see the A side of the board where the switches are. That's quite an involved job needing to remove many screws around the PCB and motor assemblies and I don't want to go damaging wires/flexicables or the laser/OWH. I want to exhaust what I can find out from the ribbon cable signals first.

Since all of those switches and the load motor just go out onto the ribbon cable, disc load seems to be the responsibility of the main board rather than part of the servo/laser control which is handled by the main servo/DSP IC151 (CXD2662R) on the BD board.

So not much progress but nothing "bad" found as yet... Thanks for watching, as they say on YouTube.

Link to comment
Share on other sites

A random thought or two:

1. The SC suffix to the board, does that mean Serial Control? If you don't care about automated operation, maybe you can swap in an MDM-7 from some much less fancy unit and get away with it.

2. The ONLY other model that supports that particular board is the one you have, the E12. If you like the features of the E10 (optical i/o in particular) then you could swap the board, leaving you with a dead E12 which is also a good source for parts. This might (provided you're careful, and I have no idea what I mean by that) allow you to check that the fault is even IN the BD board, hence my questions about the cables. You seem far more experienced and better equipped than I am, so I am sure you can judge this correctly.

3. The SIRCS is a separate board. What happens if you disconnect it? Maybe this is equivalent to 1 above without the hassle of introducing a new MDM-7 to the system.

Link to comment
Share on other sites

The silk screen printing on my BD board just says MDM7-BD, but as it's a genuine (I presume!) E10 then I'm also presuming all of the external interfaces work including the Serial Control ports (actually surprised the BD board cares about this I would have thought that a function of the Main Board). Not that I need the SC function at the moment...

I might get to the point where I have to pull apart my E12 to do some swapping of drives etc to see if I can trace where the fault may lie. As with other debug I'm really resisting that at the moment as I need the E12 working, particularly as I have shows in June and July where I must have it - so I don't want any risk of breaking it! No point me trashing a good E12 for a broken E10. When I'm through July and if I've still not got the E10 going, then I'm going to end up doing some mix-and-match to track down the E10 issues. I don't really want to break either the E12 or the E10 or use one for spares. I'd like to get both working. The default position at the moment is the E12 is fully functional (hope I haven't jinxed that!) and the E10 working would be a welcome addition. For the June show at least I'll be using the E12 and a Tascam MD-350. But the E10 would be so nice to have so I can rack two 1U units (the E12 and the E10) as my main machines (I prefer the Sony interface - I can get at all features from the machine controls, whereas the Tascam I need to have a PS/2 keyboard to access some functions like AutoPause [grrr]). The Tascam will then stay as a backup, but it's in a much larger flight case with a CD player.

But you're absolutely right - I don't know where the fault is at the moment, whether it's on the BD or the Main Board. Swapping bits with the E12 might be the only way to find out if my current debug-foo yields nothing!

I'm not sure what the SIRCS board is (or if it's separate), I don't recall coming across that one in the SM. The main guts of the machine are the BD, the Main Board (with all of the audio I/O), the front panel/display and the PSU/transformer boards. Plus small boards for the power switch and headphone jack/control.

Frustrating because I think (hope!) there's just a tiny-weeny little problem in there to fix. It's just finding the darn thing!!!

In the back of my mind though, I'm still slightly nervous that there is a "from new" issue there, given that the deck seems to have had so little use given it's immaculate condition and the odo counts. If there really is some early-life failure somewhere I might struggle to repair it. But... if I can sniff out the problem and get it fixed, I've got myself another top-of-the-range MD machine to use :-)

What other machines use the MDM7 board (*)? It would be worth me keeping any eye out for a spares/scraps machine.

Thanks for continued help!

(*) My list so far:




930/940 units seem to be doing healthy business on eBay here in the UK, no cheap prices and low bid counts to be seen here! It's nice that there's so much interest still in our beloved MD! :-)

Link to comment
Share on other sites

Try googling SIRCS.

It's sony's protocol for remote control, used in (among other things) Unilink and IR remotes. Largely undocumented, it is nevertheless a kind of standard.

Sorry, for some reason I had it in my head that there was a DB9 with a standard RS232. In fact the only interconnection is achieved by a PS/2 interface, which effectively brings out IIC control bus to the PS/2 port, the same as the lower-end models around this time that had keyboards.

(side note; I have long tinkered with the US version of the MXD-D5C, and wondered about the JB940 too, as the Japanese version of both supports PS/2 control via PCLK-MN10/MN20 - but no luck. If I understood a bit more about the way that SIRCS works, maybe it would be possible to convince them to work as slaves).

Coming back to your E10, then I've perpetrated another one of my in-the-night-can't-sleep goofs. The one which does the RS232 is the E11. But it is possible that the SIRCS interface is stuck somehow sending signals to the drive? That might explain the IIC/STOP thing.

Link to comment
Share on other sites

57 minutes ago, sfbp said:

Sorry, for some reason I had it in my head that there was a DB9 with a standard RS232.

The E10 is a bit barren on the back panel compared to the E12. The E10 has CTRL-S only (plus optical and coax I/O as you say). The E12 has CTRL-S, RS232C, parallel and relay I/O - coax but not optical I/O. Looking at the SM for these, also seems the E10 doesn't have XLR balanced analogue, I'd missed that - will confirm that on my deck when I get home though!

I see what you mean about the SIRCS board - it's the PS/2 keyboard connector board, on both the E10 and E12.

Link to comment
Share on other sites

Hmmm 440's have MDM-7 eh...

Don't you ever sleep Stephen???!! :-D

OK so I have a problematic MDS-JE530 upstairs (see other painful posts) - wonder if that chap can get me some info with the E10... oooo, I have the 530 Service Manual, lets have a look (1999 vintage it seems, but Type-R minidisc.org says...). Oh 530 is MDM-5D. Has similar ribbon connectors but the pinout looks like it's different. Shame! But, might be useful as a comparison on some signals. Hmmm... Also has some signal waveforms and a loading motor switch board. Might give me some ideas... (or some blind alleys!!!).

Link to comment
Share on other sites

7 hours ago, kgallen said:

The "REFRECT(???)/PROTECT" switch S102 seems to buzz out ok on both its contacts.

Ha! For future reference, cited in my earlier post:

"REFRECT(???)/PROTECT" - if it wasn't such a stereo-typical joke on a Far-Eastern accent applied to English! So cute!

I just learned from the MDS-JE440 Service Manual, this is "REFLECT" (not "REFRECT" as in the E10 SM :-D). So this switch probably detects MO versus CD discs, as I guess the laser read power is slightly different for a pressed/prerecord MD versus a re-recordable type, and of course the pressed MDs can't be recorded!


Link to comment
Share on other sites

I spent many hours on these boards explaining that the manual stating "OverLight Head" in fact meant "OverWrite Head". Touche

Actually the explanation given by the manual is correct. The tab is more reflective than no tab. I think i prefer surround-typical ;(

Link to comment
Share on other sites

The unit can read CD and MO even on those units that are player-only. Not needing the writeprotect slider to decide how to read. The alignment always sets up CD reading before MO reading. I have never thought about which gets tried first, but I would assume the CD is attempted before the MO, when you insert a disc.

I think when the slider is closed, the reflection is off the (white) plastic. When it's open, anything it hits is close to 1cm away, and probably not reflective.

The 1GB HiMD disk has an interesting variation on the standard disks. The slider also closes the hole behind the one nearest the front. That hole is completely absent in a prerecorded (CD) disk.

Link to comment
Share on other sites

Stephen - don't you ever sleep? Your service to the forum is unwavering!

16 minutes ago, sfbp said:

The unit can read CD and MO even on those units that are player-only. Not needing the writeprotect slider to decide how to read.

There are two switches that are part of S102 above - the write protect switch is a different switch to the "reflect" switch - the schematic is a little confusing because they can be activated independently (as I found when I buzzed my E10 out last night). As you say the write protect switch aligns with the hole on the disk where the movable flag can be present or absent. The other switch (the white pin) seems to go into the shallow pit on the (MO) disc that is adjacent to the WP hole. I guess on CD MDs that shallow pit is not there.

Hold on a second I can check this: my one and only CD MD is Jeff Wayne's War of the Worlds (everyone has that don't they???). Yes, looking at the back of the WotW disc case, it has the WP hole open, but no pit where the "reflect" switch goes. So I don't think there is any trial and error by the player - not least the full size machines anyway - the requirement is coded into the pits - or lack of - on the disc case. Every other pit/indentation/hole is the same on the WotW disc compared to a standard MO disc. :-)



ps I put an offer in on that 440 you cited - hope I can get it for the MDM-7 - and that the drive works ok!

Link to comment
Share on other sites

Well now we know definitively which hole is which. However it's tres weird that the 1GB disks blank the hole closer to the middle of the disk when they're writeprotected. This smacks of overloading to me, if you know the term.

It also raises another theory about why disks might not read (never mind write). If that (closer to the middle) sensor ever appears "closed" then the circuitry will pretend it's a CD. THAT would most certainly result in C13 (of course you know that to read, the whole servo thing has to be operable).


Bottom of page 2.

Link to comment
Share on other sites

Excellent - and the reflectivity differences between CD (pit stamped) and MO discs (using the Kerr effect of magneto-rotated polarisation of the laser light, p18) is covered on p12-15. p34 middle mentions the CD/MO switches. It all stacks up now!

Interesting case encoding/overloading you describe for the 1GB discs - seems they decided not to use the other case coding spots that were defined for future use.

ADIP - the "address encoding" preformed on the disc so the servo knows exactly where the laser is - fascinating!

Interesting read that doc, thanks for linking! (I'm an electronics engineer by day, so can make at least some sense of this doc!).

Link to comment
Share on other sites

  • 4 weeks later...

Well it's been a month or so since I posted an update (anyone care?!)... I haven't been fully idle ;-) But I'm not out of the woods yet would be a summary, as in my beautiful-condition eBay-find MDS-E10 is still not "road worthy".

As ever, just recording my findings in case anyone is interested and some of the findings might help others (purpose of the forum, yea!). Bail out reading now if you don't like waffle...!

So to recap: I have an "as new" MDS-E10 salvaged via eBay listed as not loading discs. Immaculate condition, but not initialising properly or loading disc or anything further. Replacing the load/eject belt didn't fix things. Damn!

The drive in the MDS-E10 is the MDM-7SC which is the "serial control" variant of the MDM-7 range of drives found in a number of the later Type-R (CXD2662) and Type-S (CXD2664) decks. MDM-7SC is not found widely - the E10 is one of the professional range MD desks and so MDM-7SC is not found in the bulk of the consumer MD decks around. I guess it might be in some of the high-end consumer decks, but even on eBay those aren't about at "take a chance" prices! The MDM-7SC in the E10 is a CXD2662 drive, Type-R MLDP, so not the absolute latest (which would be Type-S using the 2664).

So what have I done, what did I discover.

Following Stephen's suggestions above I looked for another machine with an MDM-7 family drive. Picked up an MDS-JE480 from eBay. Listed as disc load problem. Soon fixed that with a new load/eject belt, so I had myself a working MDM-7S1A drive. So now I can play about with the JE480 chassis and drive and the E10 chassis and drive. Note the MDM-7S1A is a Type-S based on the CXD2664 whereas the MDM-7SC is Type-R CXD2662 based.

Baseline: 480 drive in 480 - working fully, i.e. good drive, good chassis. E10 drive in E10 - won't initialise i.e. unknown drive, unknown chassis. Assuming E10 drive fault, but unproven where the fault(s) lie.

Put the known good 480 (MDM-7S1A) drive in the E10 (E10's ribbon cables). Deck initialises (progress). Drive takes a (MO) disc but won't read it. The deck seems to try quite hard (disc spins, sled moves, but some OP end-stop clattering) to read the disc but gives up with Read Error.

Put the unknown E10 (MDM-7SC) drive in the 480 (480's ribbon cables). Deck takes the disc ok (progress, the MDM-7SC drive can load a disc, I can stop looking at simple electro-mechanical disc detect/load issues). Deck tries to read TOC but fails. Seems to spin the disc in "pulses". Ends in a C13 Read Error and the deck ejects the disc.

Put the 480 drive back in the 480. It still works properly so I haven't broken it in the E10 chassis (which could plausibly have had broken chassis electronics that broke the E10 drive). Conclude that E10 chassis electronics could have a fault, but not likely a catastrophic one.

E10 drive back in E10 chassis. No change. Deck won't initialise properly. But E10 drive behaviour not changed having been in the known working 480 chassis.

Cajole the 480's wide ribbon cable into the E10 to rule out a broken E10 wide ribbon cable. No change.

Put 480 drive back in E10 chassis and E10 drive in 480 chassis. Repeat above and get same Read Error issues on both drive/chassis combinations. Repeatable at least and nothing "more broken" than before!

Use Service Mode on 480 to read E10 drive EEPROM. Extract Iop, op rec/play and error data and confirm as seen E10 drive in E10 chassis. Match, so drive EPROM is correctly readable.

Use Service mode on the E10 to read the 480 drive EEPROM. Good/expected data. This is an I2C link - although there may be another that is used for control (and is the one that results in the IIC STOP message ). Need to find that "other" I2C interface... (remember, as reported above, I got the SCL/SDA signals of the I2C up on the oscilloscope, SDA good, SCL I'm undecided...).

480 drive in 480 chassis. EEPROM read also good in Service Mode.

You're wondering why I did some of this... and it's because I'm putting off the time when I pull out my "golden" MDS-E12 (that I must have working, needed for my theatre shows!) and play drive swap with the faulty E10.

OK so I finally bite the bullet and fetch the MDS-E12 and cringe whilst I take off the lid screws wondering if this is the last time I see it work... Of course the E12 has the exact same MDM-7SC drive as the E10 so it's a like-for-like swap. I'm just hoping not to end up with a dead E12 to go with my dead E10.

Put the E12's drive in the E10 and close my eyes and cross my fingers that there isn't a bang! No change. E12 drive in E10 the same as the E10 drive in the E10. Deck won't initialise. OK so it's possible that the E10 drive isn't completely dead. But maybe there is still a fault on both the E10 drive and the E10 chassis?

Put the E10 drive in the E12 (again close eyes and hope for no bang!). E10 drive takes the disk, spins it up and tries to read, but fails with Read Error. So this is consistent with the results in the 480 - which means I can somewhat stop worrying about the slight drive type mismatch (MDM-7SC vs MDM-7S1A) being a core problem.

Put the E12 drive back in the E12. Phew. It's still working perfectly. Put the E12 back together and "re-wrap in cotton wool"! :-D

So that was all a bit unconclusive...

A week later an MDS-JE440 arrives in the post (like the one Stephen pointed to). An eBay bid that came though at the starting price! Again, disc load problems. Out of the box today. Fixed with a new load/eject belt. The 440 has the MDM-7A drive and is Type-R like the MDM-7SC in the E10. A slightly closer match than the MDM-7S1A from the 480.

So if I didn't have enough MD decks in the house before, I've now got 2 more - the 480 and now the 440 - both working, although in not-brilliant cosmetic condition - they were after all bought as donor machines. And they are 4xx range so they are pretty low-end, built to get MD decks into the 100GBP price bracket at the time I believe. They don't even have headphone sockets!

So I've been playing about with the 440 drive and the E10 drive today. Here we go again. But I'll summarise this time - since I didn't make any notes!

440 drive in the E10. Same as before. Won't initialise.

E10 drive in the 440. Now we're making progress! The E10 drive will load a disc, read the TOC and PLAY A DISC! Whooohooo! The E10 drive lives! Whilst typing all of this blurb I've been listening to it play a whole MD, so at least play seems reliable!

The story is not quite so good with record however. This is a bit more hit and miss. I can't record any kind of track. The deck/drive will go into record-pause, but when started the deck will give up after a few seconds. I've had a few goes and every now and again the OW head will drop to the surface and it will think about it for a few moments only to give up with E0101 LASER NG message. Most other times nothing happens - OW head doesn't drop and disc doesn't spin.

Trying with a simpler "record" activity, I've deleted a couple of tracks - which worked, the drive managed to write the UTOC ok. Also tried to name the disc. This worked the once but I've not been able to repeat it. Often the deck will hang at TOC Updating when Eject is pressed. This needs a mains power cycle to escape. Conclusion the OW head is not dead, and the write function of the laser is not fully dead (despite the E0101). So maybe this is a control or compatibility or some other setup issue?

So that's where I'm at as of now. Partially working E10 drive - it loads, ejects, plays, sometimes writes the UTOC. Not as yet had a drive do something useful in the E10 chassis. So I think I'll have another look at the I2C there at some point.

[Edit: Seems I might have jumped the gun a little here. Put the E10 drive back in the E10, no change as expected. Put the 440 drive back in the 440 - it's exhibiting the same won't-record-a-track and won't-write-the-UTOC as the E10 drive was in this chassis. Maybe my E10 drive is better than I thought and the 440 chassis has a snag... Ho hum, more variables in sorting this one out!]

However not much more of that for now, there's a theatre production for me to do for the next two weeks, with a couple of weeks gap before the one after. The MDS-E12 and the Tascam MD-350 will be in service there, there's a heavy music and sound effects cue list for them to get busy on.

Until next time... thanks for reading!


Link to comment
Share on other sites

Methinks you're looking at an alignment and, if that doesn't work a new OP which will also need to be adjusted. Symptoms sound classic for laser power being wrong. If you had a LPM you'd know for sure. There's another thread going on with someone who swapped in a laser, much the same.

Was a pleasure to read. Remember that a blank minidisc is not the same as one that's been written on even slightly and then erased. And a dIsc recorded by drive out of alignment will cause all sorts of strange artefacts. This might explain some of the contradictory data in your report.

C13 nearly always is a laser power problem. Most likely yours got tired.

Link to comment
Share on other sites

Thanks Stephen!

I tried a couple of other discs in both the 440 and the E10. E10 no better. The 440 with its own drive or the E10's drive does have some record hiccups - worse on some discs than others.

But you're right - all of these were used discs. I'll take your advice and try a fresh-from-the-box blank one to see what that shows... All these discs work fine in other MD decks (tried MDS-JE520 and Tascam MD-CD1 as they were available). Will see if these decks have any hiccups with anything I manage to record on the 440 with its or the E10 drive...

Thank you for the continued support and encouragement!


Link to comment
Share on other sites

  • 3 weeks later...


On 6/1/2019 at 5:45 PM, kgallen said:

However not much more of that for now, there's a theatre production for me to do for the next two weeks, with a couple of weeks gap before the one after. The MDS-E12 and the Tascam MD-350 will be in service there, there's a heavy music and sound effects cue list for them to get busy on.

Just to keep the MD fire alive, happy to report the Sony MDS-E12 and Tascam MD-350 turned in faultless service with a heavy music and sound effects burden for 7 performances of Around the World in 80 Days this past week. Get-out 'til late last night, I'm exhausted!

A different show to do in a couple of weeks. Will just need the one MD deck for that. Not sure if I'll use the Sony or the Tascam. Would prefer the Sony, but the flight case setup is such that it might be the Tascam that does the service.

After I'm through with these, I'll be back looking at this E10 issue and hope to have a fix for it. Would love to have the E12 and the E10 racked together for these gigs...


Link to comment
Share on other sites

  • 1 month later...

The E12 got the gig over the Tascam! Also a first outing for my newly acquired Behringer X-Air XR16 if you readers are in to live sound. E12, XR16, 6 small diaphragm condenser mics and 2 boundary mics. Great concert run for charity with some close theatre friends. E12 faultless and a Godsend to have. Doing lighting at the same time as sound, so having that E12 just working perfectly at a touch of a button is why I’m back using minidisc for my theatre work!

Hoping to get another look at that E10 soon...


Link to comment
Share on other sites

  • 6 months later...

OK, so I've cheated now. But don't think this is the last of it...

So I picked up another E10 at a reasonable price (*). Cosmetically not perfect, but I just transplanted the main board from it into my not-a-happy-bunny E10 chassis, so now I have a working/nice condition E10 to add to my ever growing range of MD decks!

(*) I don't really want to revisit this. The E10 arrived and I plugged it in quickly as dinner was served... Well the transformer grunted most unfavourably at me and I turned it off quick. Damn, I've bought a duff I thought. Only to find that the berk who shipped it to me (in the UK to me in the UK) had it set to 120V (cf UK 230-240V mains) and the fool in me in my rush to give it a whirl before dinner hadn't realised it had a voltage change switch (some don't) and I hadn't checked. It was set to 120V. Changed it to 240V and nothing. No display. Great, I thought, I've just blown the darn thing up straight away. Opened it up to check the 1A 20mm glass fuse - intact. Damn, could be a thermal fuse inside the transformer - well that would make it WEEE at best. Spent some time faffing with it - compared the transformer voltages against my other E10. Look good, maybe it's ok...Took the PSU and swapped it into my other (not happy) E10 and the PSU seems to be fine. Lucky boy. OK so maybe I've blown the regulators on the main board, or even the fluorescent display (which take an unregulated 42V ac from the transformer, which with my AC setting mistake could have been 80V+). Swap the main board into my other E10 chassis - and it works! Phew! Swap it back and it works! It seems the fluo display ribbon cable wasn't originally seated properly - could be the thing that actually saved the display from my over-voltage mistake! So end up making a good E10 with the original PSU, the newly-acquired main board and MD drive, and all is well. So the main board from the original E10 is sitting there in the tatty chassis until I have the energy to try and debug it more. So... let that be a lesson to us all. Check the voltage selection switch before plugging it in! Here endeth this tale...

Link to comment
Share on other sites

Yeah, having acquired the "magic" Gold Peak charger for prism batteries (NH-14WM etc) that actually charged Sony's gumsticks properly, I took it on a holiday to Europe and..... BANG! I had failed to notice it was 120V only, unlike most charger devices. My sister was not amused when the electrics in her posh condo tripped with it. Now I can't even get a replacement. Sigh.

Link to comment
Share on other sites

  • 7 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...