Jump to content

MZ-NH1 Can Record, Cannot Edit

Rate this topic

Recommended Posts

Hi all, so a bit of a weird one this. I've tried to search for someone having a similar issue, but I couldn't find anyone - apologies therefore if this has been solved before.

I have previously been able to record, format, edit and title HI-MD formatted discs on my NH1. I haven't used it for a year or so, and have come back to find that it's lost functionality.

I can play discs fine. I can record onto blank discs that I have previously formatted (via optical in, I don't use sonic stage). I can T mark tracks. The unit can tell when the disc is protected or not and won't do anything when it is. 

However if I go to edit a Hi-MD formatted disc I just recorded on, I only get one option in the Edit Menu and that's Format. If I try to format it says No Edit. I cannot divide, title, delete tracks, nothing.

I'm mainly confused because it will record, but it won't edit? Is this a dead magnetic head?


Link to comment
Share on other sites

OK, cool, so this is the current situation.

Record to a blank, Hi-MD formatted MD: Yes

Set tab to protected -> Press Menu -> Press Edit > "PROTECTED" flashes.

Set tab to unprotected -> Press Menu -> Press Edit >  Format is the only option on the list. 

Press Format -> Select Yes -> ....and it just formatted the disc?! 


So in trying to respond to this, and having done nothing, it has formatted the disc. I don't understand why.


I have another disc here that was recorded in standard SP, with standard formatting, and I cannot edit it or format it. The edit option isn't available. I've never been able to format discs like this tho in this device, I've had to format them on a standard deck, then reformat the blank as a Hi-MD before recording.

Link to comment
Share on other sites

I think the problem is this: there is something called "disc mode" which determines:
a. what format you will be offered when you try to initialize the disk (Hi-MD or NetMD/MD)
b. what a blank disk comes up as

The reason for all this is that all Hi-MD units have to present themselves differently on the USB bus because NetMD uses a different, older, proprietary protocol from HiMD. The latter, whether 1GB disk or "legacy" disk reformatted to Hi-MD, is your basic SCSI device protocol. Being Sony, they absolutely had to tweak it so that the format is secure (fear of computers and all things related?), and to get stuff off a disk which is corrupted by a single bit error requires low-level access they never gave out to mere mortals.

Disc mode can only be set by pushing buttons on the drive itself.

Oh, by the way, the device presents a different USB device identifier to the bus in the two modes, so it really is like having two different machines which never quite meet. For playback, though, the switch is automatic: insert a disk and it will "switch machines". This may possibly be affecting your operations.

Sadly all sorts of weird things happen when you write protect a Hi-MD disk. Bad design!

Link to comment
Share on other sites

If I go into Options -> Disc Mode -> MD, then pop out he disc and pop in my regular formatted MD with recordings already on it, there is still no edit menu.

To reiterate, I'm recording via optical in, I am not doing anything with a USB cable. Therefore I can't see what that would limit my edit options or only allow me to format a Hi MD disc periodically. Seems to me that there is an internal, physical failure that is occurring here?

Link to comment
Share on other sites

If that disc was NOT created by you but by someone who transferred stuff from PC --> MD then it will all be locked.

If you recorded it yourself from analog or digital input (mind you there's an issue of SCMS I suppose) then I am mystified.

Wait a sec - this thing is smart. You cannot expect to see an edit if the disk is write protected. That's why I asked about the WP switch.

Link to comment
Share on other sites

You. Are. KIDDING. Me. 

*bangs head against desk*

So another case of RTFM, literally the first thing I usually advise others. Well, apologies for entirely wasting your time. I have used this unit for years, I put it down for 12 months, and suddenly I've forgotten how to tie my shoes it seems.

Thank you. Not just for humouring me, but for being so pleasant in your pronouncement of my mental infirmity.

I hope that, if nothing else, the next time someone googles "I can't edit my recordings on my Sony MiniDisc Recorder" they can read this and realise "you need to use the remote, not just the unit" and "maybe read the manual again?" as a nice simple solution!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...