Jump to content

Sony MDS-JA20ES Issue

Rate this topic


Recommended Posts

Hi - One of my Sony JA20-ES decks became a little quirky on me the other day. After playing I went to eject the disc and the unit started to make a continuous clicking noise directly underneath where the disc is stationed in the unit during playback. It would not eject the disc. No buttons would cease this malfunction other than unplugging the unit. I tried plugging and unplugging the unit many times in an effort to reset some sort of function. No luck though. I took the cover and bottom plate off the unit and searched to find anything awry. I located a white piece of rectangular plastic (with gear threads on just one end) which appeared to be out of place. It was not broken off, just lodged inside. It has a number "4" stamped on it. I removed this, plugged it in and now seems to be working great. I am wondering if this piece came loose and would need to be put back to its orginal position? I certainly don't want it to cause problems down the road. Anyone out there familiar with a JA20-ES's internals? I can send a picture of the piece if necessary.

Link to comment
Share on other sites

  • 3 years later...

Hey guys

i got a mint JA20Es and had to rework the mechanics of the tray. Same thing as OT had as i suppose that his (BU-B) has broken too.

My Deck is making sttrange things now that teh tray does work.

I turn it on and it comes up with blinking "close" . After pressing open  and close again .. it directly  states C13 read error ( i love when this shows up :D ) and opens automatically. Now.. if i close it it again  "Toc reading" shows up and the Disc can be played back with no Problems.


I tried shortening the BT Board pin 1/3 ( where the Battery is in ) as stated in the SM but to no luck.


What the Hell is going on.. did i miss something ?


When i first plugged the Deck in the Display was dark and it was constantly clicking and whirrling because the BU-B had broke loose and some other mechanical parts were broken. I fixed all this.. but now iam out of ideas.


So does anybody got a clue what is going on in the unit ?

Link to comment
Share on other sites

I have the same unit and also have been having an issue with the tray, although it is somewhat different.  I don't have a "clicking" issue.  But upon inserting a disc and trying to close the door it stops just before the tray goes in. At first I thought it might just be an issue with the disc.  So I tried several and it happens on about half the discs.  Even brand new Biancas and the better TDK ones.  Usually, I can try several times and it will finally go in.  Recording and playing are both fine.


These decks are like 15+ years old.  I'm sure its because the moving parts do wear with age...

Link to comment
Share on other sites

I have the same issue as does culp4684 and I have had - and continue to have - other problems with the JA20ES. I bought mine used on eBay 3/4 years ago, I'd guess. Like culp4684's JA20ES, mine eventually will play and record...so far. The JA333ES I had was also flaky. I agree with the conclusion that the moving parts will eventually just wear out. Those of you who have the skill and workspace to maintain and repair your MD units are truly fortunate.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...