Jump to content
Sony Insider Forums

MZ-NH1 doesn't displays in VISTA (32bits) running on Virtual Box

Rate this topic


Recommended Posts

Hi,

 

I can hear the chime connexion when I plug and unplug the device, but no mass storage display in Explorer or Windows disk manager.

 

The disk doesn't show up in SonicStage (SS43 Ultimate) either.

 

After automatic installation of the driver Windows mentioned it was not installed correctly. In the Device Manager the USB disk Storage mentions a yellow "!". (Multiple installations / uninstalls of Sonic Stage couldn't correct this, nor update driver via Windows did)

 

My MD unit is set on the HIMD disk mode. (not NetMD)

 

I wonder if this glitch is the result of VISTA being installed on a virtual machine (VirtualBox) or if it's due to VISTA itself.

 

The problem may come from VirtualBox (latest version 4.3.28 r100309) because as a virtual machine it handles all the drivers via its "Guest Addition" program making them to be able to run correctly on the real computer.

 

When I run "Microsoft Fix-it" program on VISTA (a tool developed to correct non detected devices) it detects it but says it cannot correct the problem. (This tricky question seems wider than only touching MD devices : it occurs with a Canon Scanner even though I applied a corrective driver, developed by Canon specifically to run with VISTA).

 

Any idea to help is welcome !

 

 

Link to post
Share on other sites

1. Get rid of all NetMD devices (see the stickied post on "Slow MZ-RH1 upload") in device manager (you will have to uncover the hidden ones using this technique.

 

2. Is your Vista 32 bits or 64?

 

Pick the correct driver from the downloads section and "update" or install the driver (probably a yellow exclamation mark) in Device Manager using that (unzipped) driver package.

Link to post
Share on other sites

Problem solved !

After trying multiple suggestions (including going back to previous 32bits SP1 VISTA version !), I found this was not a specifically MD issue, any USB device wasn't recognized by Windows (scanner, Seagate Storage, floppy disk etc.).

Following the advice of a post in VirtualBox forum I installed "Oracle_VM_VirtualBox_Extension_Pack-4.3.28", and now all is working OK.

This pack installs drivers for USB 2 connexions (among several other drivers). It was hard to guess this could solve the issue because on Windows XP — previously installed on Virtual Box, where SonicStage and MD devices would run correctly — this pack was no need.

(The helping post on Virtual Box forum is this one : https://forums.virtualbox.org/viewtopic.php?f=2&t=66085#p312726)

The way virtual machines handle and convert drivers so as to make them compatible with the host machine is somewhat tricky.

Edited by Giboulet
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...