Jump to content
Sony Insider Forums
Sign in to follow this  
NGY

Sony Minidisc decks with C13 Disc Error - my learning path

Rate this topic

Recommended Posts

UPDATE: I have changed the original title "MDS-JE510 Disc Error" of this thread. I intend to collect my C13 Disc Error cases into one topic.

* * * *

MDS-JE510

What a silly error I faced today...

Yet another 510 that came with the known troublesome load/eject. I have already fixed half a dozen of 500 or 510 with this problem (or sudden switching on from standby, or disc error upon loading a disc - as these all root in the same issue), so I performed the usual routine (fairly straightforward fix, but requires a complete strip down of the drive, and some delicate repair work on miniature parts). When completed, I put the drive back into the deck and powered up. Upon inserting a disc, I heard it spinning up, so far so good. It tried to read the TOC a couple of times, changing revolution and seeking OP, but then it spat out the disc, again with "DISC ERROR". OK, let's check the laser I thought, but both the settings and the measured mW values were spot on. Then I checked the error rate, and it was very high - increasingly higher in the MID and OUT ranges, that called for a deeper inspection.

I removed the lid to take a look at the drive. It become obvious, that the disc hit up and down quite a bit, ~2 mm on the edge. I thought it was my much (ab)used test disc. With a known good disc, the same happened. First I suspected the axle of the spinning motor, whether it got bent once the last disc the deck had eaten, was pried out violently. But the shaft was running true. After trying several discs, and most of them got ejected with the error, I took a closer look at the magnetic hub that holds the disc in place, and found this: a little bulge, probably some burr left by injection molding of the part. Once I cut this little piece of plastic off, discs began running way smoother After properly adjusting the traverse and focus bias I rebooted the deck, and voila, no more disc error, and it plays/records as it should.

But what bothers me, how on earth this deck had worked so far at all? Or, is it that the laser tracking/focusing mechanism did compensate for the rocking discs, but only until it got somewhat "tired"?

DSC02781.jpg  .  DSC02782.jpg

Share this post


Link to post
Share on other sites

MDS-S40 (apropos of the similar case of an MDS-JA22ES)

This is just a link to a C13 story in another topic - everything is detailed there, so I would not duplicate everything here.

Essence in a couple of words: a broken part in the OP positioning mechanism caused the error.

 

Share this post


Link to post
Share on other sites

MDS-JE520

Yesterday night I played with a faulty deck, and here is what I found. I bought this MDS-JE520 on ebay for parts originally, it was fairly cheap, so I did not mind stripping it down. But as usual, first I wanted to understand, what is the cause for the fault. The deck would not accept any discs, after loading one, it would try to read it, but then it would eject with C13.

I had already some idea, that there can be multiple reasons for a deck rejecting a disc, however, here came another one I would have never thought of.

Before jumping on it, here is a little puzzle: can you spot any differences? Left one is the drive of the 520 exhibiting a C13 error, right one is another 520, that works OK.

014399.jpg  .  024396.jpg

 

Yes, one part is missing, a spring! Here is the "difference":

034121.jpg

 

I had no clue, where actually the spring was, because it was not inside the deck when I opened it. More than that, how could that spring jump off? It takes an effort and a tool to take it out of its place.

OK, but then what's the problem? It looks that the drive loads the disc halfway only, and cannot lower it into its nest, because this spring is responsible for holding the loading tray in the required position. Once the disc is not fully loaded, it would certainly not spin, and the laser would not read anything - disc error, eject.

On the left the disc is stuck halfway, on the right it is properly loaded (well, I did it manually, for the sake of the photo):

044397.jpg  .  054398.jpg

 

For a quick test I lent the same spring from the other 520, and presto, the C13 error disappeared!

Now, how can I destroy this unit for parts, when it is in full working order :-) ?

 

Share this post


Link to post
Share on other sites

It looks like you're going to have to keep it in one piece and just welcome a new member to your MD family:)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×