Automan

MDS-JB940 Relay Clicking All The Time

Rate this topic

8 posts in this topic

I have owned MiniDisc machines from Sony's very first model and have recording from that time.

Anyway, I thought it was time to try a few of my players out again.

The portables I have tried so far still worked but my MDS-JB940 is under the weather.

At first it worked but then would not eject and this seems to be a common problem so I ordered the belt.

Anyway, after helping that disc out it seemed to be okay and I put the lid back on.

It worked all day playing several discs and I left a disc in putting it in standby (they use 1 watt in standby).

This morning I turned on my AMP, pressed play on the MD remote but instead of playing all it does is make a relay clicking noise (The relay feeds AC power to the main transformer that feeds most of the machines electronics, it has another small transformer on all the time feeding the clock and remote interface).

Unplugging from the mains and plugging it back in just makes the relay click.

I have looked at the threads in this forum and google searches but cannot find any mention of this fault.

The comprehensive Sony Engineers manual has lots of fault diagnostics for the disc unit but not the power supply unit.

I am hoping that it is just a power supply fault and perhaps one of the very large capacitors on the AC Board has failed (no sign of any bulging).

Thus I have ordered replacements for C927, 924, 921 and 401

Has anyone get any other ideas relating to this fault?

Share this post


Link to post
Share on other sites

My first idea was that the main processor detects an error and sends the standby signal to the relay driver circuitry. But there can be multiple other causes that led to this symptom.

One thought: before replacing those filter caps, it might be worth doing an ESR check first. An acceptable ESR value might save the time of the replacement.

Share this post


Link to post
Share on other sites

Probably mechanism jammed or something short circuited. If standby light is red, then I would suggest: Unplug from mains. Now put into service mode by plugging in with both AMS and STOP depressed at the same time (page 4 of the manual). If that gets you nothing, then I'm wrong and it's the power supply. Disconnect the MD side and see what happens. Sounds like you have this in hand by the stuff you've ordered already.

One person on here DID have the identical problem in the last 12 months. I don't have time to find it, but you should be able to. I think it was a capacitor.

I've definitely seen decks suddenly do strange things and be perfectly fine after disconnecting from mains and fiddling about.

Share this post


Link to post
Share on other sites

Not to sure what the ESR check is?

Can't run the unit diagnostics as all it does when you plug the mains in is constant clicking of the power relay and none of front buttons do anything.

Just tried again, the same clicking. It does the same also if I unplug the a.c. To the main transformer.

Also ordered the four large caps on the main board which do the +7/-7v supplies.

C417/8 and C421/2

 

Share this post


Link to post
Share on other sites

The capacitors for the AC Board arrived today and in under 30 minutes they were fitted.

Plugged the power back in and this time the relay operated and stayed operated with the unit drawing 14.4watts of power.

Only front indicator on was the standby light and the button did nothing.

I then realised it was making every few seconds a screaming noise so I unplugged it.

Could see not really see why so plugged it in again in with the TV turned off.

The noise was coming from the MD Mechanism, disc not spinning but then I remembered eject was not working well (belt still not arrived).

Anyway, I gave the mechanism a little help (left top corner) and the disc ejected.

On power up then the display said Initialising and then said "No Disc"

I put the clock right (I may investigate the battery soldered to the main board) and I guess now better wait for the new belt to turn up.

I ordered the belt before the other parts.

2017-05-03 12.55.35.jpg

2017-05-03 12.56.02.jpg

Share this post


Link to post
Share on other sites

Yup well done. Stuck mechanism. Probably replacing the caps undid some sort of safety interlock, I bet you'll find they're not actually blown.

Kind regards

Share this post


Link to post
Share on other sites

Still waiting for my belt but otherwise it still is working.

I will be brave soon and try and make a new recoding...

Share this post


Link to post
Share on other sites

Posted (edited)

My belt has finally arrived and eject is a lot more swift in operation.

Pretty easy to fit it, unplug 2 x ribbon cables, remove four screws through rubber mountings and with a dental pick remove the old belt and fit the new one (though the front of the drive).

I also ordered a capacitor test meter so I will see what it thinks of the ones removed from the "AC Board".

Pictures posted in the reverse order.

 

2017-05-05 15.22.29.jpg

2017-05-05 14.07.48.jpg

2017-05-05 14.06.30.jpg

2017-05-05 14.03.51.jpg

Edited by Automan
Picture Order Backwards And Typo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now