Jump to content
Sony Insider Forums

Sony MDS JE510 unusual eject problem

Rate this topic

Recommended Posts

  • Replies 51
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images


Like: have you tried different disks. Is there any difference across brands? If you carefully apply a little pressure (instead of heat) to parts of the frame does that change anything? Does the disc look like it is spinning smoothly? Is the disk seating properly? Are there different noises under different conditions of above? When you did the heating (which I advise no more), which parts were you heating which had an effect?

Feed us with some information then we might have other ideas. We don't have the machine in front of us, you do. Just treat it gently and try ideas carefully. Otherwise it will become a piece of scrap.

I have tried about 20 different disks of three brands including Sony and Hi Space, others are no name

Tried putting a little pressure but no impact. Only pressed on pieces easily reached, including the sled.

The disk looks as if it is seated properly and in setup mode I can move the head across the whole platter.

There is an occasional noise but not frequent and a little like it can't move.

I have also cleaned the rail that the little round pin on the head slides along.

So far no progress

Any other ideas I am happy to try

Link to post
Share on other sites

Some further information

Tried all the stuff recommended by John-John. Including

  • cleaning the laser
  • putting a heat shrink tube round the slider switch
  • Oiling the wheel supports
  • cleaning the contacts on the strip connectors
  • Sent him a mail off his site but so far received no reply

After all this same problem, though again after heating the unit to shrink the tubes it worked.

On setup Cplay mode still a very high level of errors. It does however move between the three settings


Link to post
Share on other sites

It might very well be that the laser is weakening. What makes a little difference to me is how the TOC reading sequence happens on his machine. Based on his video above, my observation is that the deck probably does not even get to the point where the laser attempts to read the Lead-in area. That is, to happen before it gets to reading the TOC. These two readings are done on two different reflectivity layers, that the laser also has to accomodate to. Whether or not it is a laser issue or a mechanical problem is what we need to find out. This was what I tried to get hold of in my deleted post above. Not sure how to step forward from here. I mean, I do know what I would do if the machine was in front of me. What I don't know is how to post that sequence here without being charged responsible for any possible damage or personal injury. I never ever meant here to hurt anybody or ruin their machines.

Link to post
Share on other sites

Thanks NGY

I am not sure how to go further.

It just seems odd to me that if I gently heat it with a hairdryer I can get the machine to work.

This seems to me that it isn't a laser problem but something mechanical. Either a part which is expanded by the heat or a lubricant which is melted.

If it was a laser problem then I could increase the laser power, but don't want to do this as it could cause other problems 

Any suggestions gratefully accepted

Link to post
Share on other sites

Don't spin too much on this "heating the drive with hair dryer". I see your point, but, as already mentioned before by others, this is totally uncontrolled and can impact many things besides the ones you mentioned, thus can make the situation worse, rather than better. Take the OP for example: say 10...20 °C increase in its temperature over ambient can result in higher laser output - and if it was the case, I could imagine if it helped. However, as  the laser diode gets hotter, its current increases, that heats the laser even more and so forth, then at a certain level the laser diode just simply burns out. How far this process gets is totally out of your hands.

Here is my rank of possible causes (based on the information I read here, and I might as well be wrong too):

- one of the sensors - i.e., either the switch  that senses the loaded disc, or the one for the sled parking position (or both, or even more).

- weak or out-of-focus laser

- spindle motor

- anything else

From this you can conclude I give a low probability of it being a lubricant problem. Normally, I would follow this order when trying to confirm/exclude causes. Nevertheless, you can check your laser power, if you have the proper gear for it - an LPM and an MDM3 test jig with a DMM hooked on, as a bare minimum. Without these pieces of equipment all you can do is to proceed (very carefully) like described here or here, for example.

And stepping back to the TOC reading process above for a moment: I can do a short video of one of my MDM-3 decks, what happens when a disc is loaded. You can then compare it to your machine, looking for any differences. I just need some quiet time to do it - will get back to this thread soon.

Link to post
Share on other sites

Thanks again  NGY

Unfortunately I don't have the test gear, the other problem is that I don't know anyone round here who has.

So I guess I will have to keep trying to find someone locally who can help.

I could put the numbers from various tests in SM if useful

Link to post
Share on other sites

OK Got some numbers

Laser check

  LD 0 9mW $10,   LD 7 0mW $90,   LD 0 7mW $00 or $0D,   LD 6 2mW $80,   WPmr  $80 not sure of the alpha characters

FBIAS Check 7071/00  C=02


MID C1=6970AD=00 to 7350AD=75 ; IN C1=6192AD=00; MID C15114AD=00; OUT C1=4592AD=00

For another Sony mini-disk

IN 2650AD=00 to 2822 & 2650AD=02 to 2751, &2616AD=01 to 2785, 

MID  2770AD=00 to 3074

OUT  2841AD=00 to 3010

EEP 51 14

If there are any other readings let me know and I will try again. I only have this device so it wasn't possible to use another source for the disks

Link to post
Share on other sites

OK, a few comments:

- Laser Power: "LD 0 9mW $10,   LD 7 0mW $90" seem to be factory settings. Good news, unless someone tinkered the trim pot on the OP - would be worth to measure it with a multimeter (although "LD 6 2mW $80,   WPmr  $80", i.e., those two figures matching each other is a good feedback - but I cannot detail it here).

- CPLAY Mode error rates: these high numbers in the multiple thousands region (especially this "7350") are worrying, they show that your laser is set off big time (or even "dying" as Stephen said)

What makes things complicated is that yes, it can be a fading laser diode, but it can just as well be a mechanically damaged OP (see some photos here), or a totally misaligned (out of focus, out of track, wrong gains, etc.) laser. Either way, it can be a cause for the deck not able to read the LEAD IN area - but it can be something else too, i.e. one or more of the sensor, as already mentioned.

Anyhow, you can try your laser whether it is still capable for some "normal" operation. If the visual inspection (MACHINE AC CORD PULLED OFF!) shows the OP is not mechanically damaged (see linked photos above), then you can try the trial and error part on the laser READ settings (i.e., the one for 0.9 mW) - and forget the WRITE settings, as it does not impact your original issue at all. You can try  going up from the $10 to $14...15 without damaging you laser, but do it only incrementally - once you see a result (i.e., deck begins to read the disc), no need to stretch the laser any further. If no result, at even $15, then reset the value to the initial $10.

The SM has a good chapter on how to properly set the laser, but the trick is you either have to have Sony's test discs, or another, known good machine to make discs you can use for these settings (preferably not a portable, as Stephen pointed out in the other topic linked above). And, this is a painfully tiresome process, may take an hour or even way more, or no success at all, if your laser is too "stubborn".

Link to post
Share on other sites
3 hours ago, Ragodin said:

Only difference is that I now sometimes get 'disc error' but not always

This is actually a good sign - in terms it is giving us a direction to follow.

It shows, with the increased setting the laser managed to read the Lead-In area, then past the Lead-in it progressed over to reading the TOC area. There it could not then read the TOC properly, thus still could not yet recognize the disc. (The "DISC ERROR" message on the 500/510 machines is equivalent to the "TOC ERROR" message seen on later models.) In my eyes, this is a bit of progress, although there still might be other issues.

Can you compare then the actual movements of the sled (I mean, after loading a disc), to the previous state (on your video above)? I would expect now some wider seeking from the parking position, than before, as well as a few attempts from the drive to read the disc (spindle spinning up a few times, and laser giving an audible "click-click' noise, before spitting the disc out).

Now, if this machine was in front of me, and I did not have an LPM (I actually do, therefore I can obviously easily measure a laser properly, but let's just say "if", so you can give it a try if you wish), I would probably try going incrementally up above $15, maybe a few more ticks max.


a) if the assumption above stands, then your laser is already going end of life soon. In that case, you can't really do anything wrong by stressing it a bit more, as it will give up soon to the ghost anyhow; or

b) if it is not fully the case - i.e., still there is some mechanical or sensor issue behind -, then increasing the READ power only (and only that much I indicated, that is about 0,3...0,4 mW  max.) cannot really burn out the laser diode. (Again, don't touch the WRITE settings!)

If no result, again, write back the original $10 value.


And let's then play the game this way:

DISCLAIMER: you try all this at your own risk - I must not be held responsible for any damage that might occur to your deck. I definitely have no intention to screw anybody's machine, and I would never suggest anything I am not 100% confident in that being safe and appropriate, and that I would not do on my own equipment in case.

Link to post
Share on other sites

Latest saga

Yes I increased the power and the head moved - which is good.

Unfortunately when I took it to pieces to take the photo I must have disturbed a connection as the disc no longer turns. To verify this I used SM CPLAY and it does not get to the point of showing the errors. I tried it on IN, MID and OUT. The head moved a little each time but the disc stayed still!

Looks as if we are close to the end of the road.

BTW I contacted Sony and they said that as it was bought in 1997 they no longer maintain this model.


Link to post
Share on other sites
19 minutes ago, Ragodin said:

Looks as if we are close to the end of the road.

Ah come on, don't give up so quickly! :-)

Make sure any cables are clean and seated properly.


19 minutes ago, Ragodin said:

BTW I contacted Sony and they said that as it was bought in 1997 they no longer maintain this model.

:-D No commitment these days you see... Good job there are these forums!


Link to post
Share on other sites

might be totally off beam here, diddent 12 volt vids have a problem with a md deck doing strange things, and he found that is was the super cap causing it as it was at the end of its life, just thinking outside the box so to speak.

Link to post
Share on other sites
11 hours ago, Ragodin said:


Do you have a link to this video, please

its unlikely but you never know,other responders to this thread are far more knoledgeable than me


Link to post
Share on other sites


Thanks once again, but I don't think this is problem. The battery he talks about does lose the voltage very quickly but this would have been there since the beginning so is unlikely to be the cause of the disc not spinning.

At he start of this process the disc spun and the head didn't move; now the head moves but the disc will not spin.

I have taken it to bits and cleaned all the flat cable connections twice

Don't know what else I can do.

Link to post
Share on other sites
On 3/26/2021 at 9:34 AM, Ragodin said:

All cables cleaned but still no rotation of disc, though the head moves!

Sounds like the MCU is still not happy with something. It can still be laser related (i.e., IOP way out of range, or the lens position feedback circuit sending weird signals, etc.), but it can be else too.

8 hours ago, Ragodin said:

I have taken it to bits and cleaned all the flat cable connections twice

Don't know what else I can do.

I don't know, how deep your are skilled electro-mechanically (and how comfortable you are with stripping the drive further down), but if I were in your shoes I would definitely give a chance to cleaning and lubricating all those sensor switches.

This is where you need to dig down to - on this board there are six (6) switches, that (mainly, but not exclusively the two in the middle) may need thorough cleaning, removing dust and/or oxides from the sliding contacts, then apply some good lubrication (look for Kontakt 60 and 61 for example).

MDM-3 switches pCB



To the point @M1JWR raised: yes, it would make sense to quickly check all power rails, against the values specified in the SM.

WARNING: ELECTRIC SHOCK HAZARD! You must know what you are doing before opening the lid and doing measurements in a live equipment.

Link to post
Share on other sites

Lubricated the switches. Result still the disc does not rotate.

Also must have caught a finger on the upper head as that catches on the frame now, which it didn't before.

Really feel that this is the end - as they say I have given it my best shot.

Link to post
Share on other sites

Ahhhhhh the old interlock problem. Do not panic. This is exactly how most of these machines end up in the bin. Mine included - my first deck, and the only one that I ever had to get rid of.

Insights please NGY!?

Link to post
Share on other sites

Regarding the OWH:

20 hours ago, Ragodin said:

... the upper head as that catches on the frame now, which it didn't before.


17 hours ago, sfbp said:

Insights please

Jonathan had posted some good photos and explanation on this here. Nothing to add, really.

After re-reading Jonathan's post, a quick note: I see he had also mentioned the same "trick" of fooling the deck to do a load sequence without a disc, to view/access some parts at the area normally covered by the disc. This is exactly the same that I described in the deleted post above, and that @kgallen raised as an issue.


Regarding the original problem ("unusual eject"): I don't feel I have all necessary bits and pieces of information to tell a more or less solid diagnosis. As the OP himself seems getting to where he finally gives it up, I don't see any reason for new questions and checks to get any further. My experience is that nearly all MDM-3 machines are repairable, regardless these type show the broadest variety of possible troubles (maybe just a volume thing). Whether or not it is worth the effort, depends always on the owner.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...