Jump to content
Sony Insider Forums

Machines that were sold as broken..but worked fine

Rate this topic


Recommended Posts

Has anyone ever bought an MD portable or deck that was sold cheap as faulty but when you got it it worked fine? What was the 'fault'?

I have had a few. An MZ-R50 in as new condition for £5 that 'refused to play' but when I got it all that was up was the HOLD switch was on. After releasing hold it worked fine.

Yesterday I had a Sharp MD-MT90 come in the post with remote and in lovely condition. 'Does not play' but all that was wrong was it had an LP4 disk in it which it is not capable of playing. Popping in a standard SP disc soon got the machine spinning happily.

So what cheap 'faulty' units have you had that were working perfect?

Link to post
Share on other sites

MZR50 units are beautiful well crafted machines.

Its a shame i had to bin mine years ago.

They are so cheap on ebay though i bought another along with the r35.

Battleship build :)

In the UK portables are so cheap its not worth gambling on something working when it is stated that it doesnt work.

Of course the RH1 is the exception :(

Link to post
Share on other sites

Well being an engineer I like a challenge sometimes but in all my MD'ing years the only true faulty one was a new one from Currys (blue R50). Ah yes, the RH1. When they were being discontinued my local Sony Centre was doing them at £190 each. I bought one to use for what its good at and then went back for the rest of the stock - two were left. I have those in storage (not been out the box) but I now worry about the battery going bad in storage. I bought some Hi-MD disks at the same time but at £15 for 2 they were a bit expensive still.

Link to post
Share on other sites

In the UK portables are so cheap its not worth gambling on something working when it is stated that it doesnt work.

Of course the RH1 is the exception :(

You lucky guy. Here in Germany, some MD portables are ridiculously expensive. Many NetMDs or HiMDs reach completely unjustified prices here. The same goes for the Sharps that feature their "magic sonic ingredient" 1Bit. I wish, people would know that that was only a Class-D amp and that those amps are also used for amplifiers in clubs - I bet they wouldn´t buy them anymore.

Link to post
Share on other sites

I bought a car unit, an MDX-C150, off of Ebay a few years ago and I won it for $0.99. Shipping was $11 though. It said it was faulty but when I hooked it up at my friend's house, it worked just fine. There was even a store bought Bruce Springsteen MD in it. I used it for a little bit and then resold it on Ebay after I got an MDX- CA790X for my car.

Link to post
Share on other sites

Bought a Sharp MS701 for £3 last year, only thing I can find wrong is the backlight on the remote is intermittent. Everything still functions ok on both player and remote. As the Li-ion battery was dead and there was no mains adaptor or AA battery case I'm guessing the seller couldn't check it so sold it as spares or repair to prevent any comebacks.

Looking back now I really don't know what made me buy it, but I'm glad I did!

Steve

Link to post
Share on other sites
  • 3 weeks later...
  • 1 month later...
  • 2 weeks later...

I bought 2 MZ-RH910 and 1 R700 for $122 on Ebay last year that were being sold "as is". I didn't know if they were going to work or not and there were no accessories. When I got them, I was worried because they looked like they had been through hell. The face, though not the display had multiple scratches. I don't own any Hi-MDs, but I put in a regular MD praying that one of the RH910 players would work. The motor was loud and it cranked and cranked, but it played eventually. After a few days of using it to and from work on the subway, they power up no problem and play and even get recognized by my computer. I guess they were rusty. I probably should open them up and use some canned air on them. They even convert regular MDs to "Hi-MD" data discs. I've been using the R700 (I really don't like the design and it's an ugly lime green colour), but recently it's started to skip and there's some strange clicking noise when I play my discs.

I also bought 10 Sharp 1Bit players off Ebay. They were also being sold "as is". They all work, but unfortunately I can't get them to be recognized by my computer. Does anyone know about this?

Link to post
Share on other sites

Yeah and it usually involves the battery corroding. Cleaning the contacts and battery/using a different battery seem to do the trick,

A little vinegar on a Q-Tip or toothbrush usually does the trick. I had one machine that had corrosion, and didn't work with the battery I had, but once I cleaned it it was working just fine. A LOT of people have no idea that battery corrosion usually isn't so difficult to clean

Link to post
Share on other sites

Bought a Sony MZ G-750 which was 'for parts' (I bought it for the FM radio cable) but when it arrived it powered-up and worked perfectly. No issues at all! Only paid £15 for it, including postage and packaging, and it is in immaculate condition!

My BEST EVER, was a Sony MDS JA50ES (a real monster of a thing!) which I bought "on a whim" for £20 plus £20 p&P with a fault, where it was described as "working, but no display". Got it home, fired it up, had a good play and found that the 'Display' button on the front was gunky and jammed-in. Gave it a careful clean with contact-cleaner, and now the whole thing works great!

Link to post
Share on other sites

Bought a Sony MZ G-750 which was 'for parts' (I bought it for the FM radio cable) but when it arrived it powered-up and worked perfectly. No issues at all! Only paid £15 for it, including postage and packaging, and it is in immaculate condition!

My BEST EVER, was a Sony MDS JA50ES (a real monster of a thing!) which I bought "on a whim" for £20 plus £20 p&P with a fault, where it was described as "working, but no display". Got it home, fired it up, had a good play and found that the 'Display' button on the front was gunky and jammed-in. Gave it a careful clean with contact-cleaner, and now the whole thing works great!

Look like your JA50ES is the BEST deal I have seen here. I got a JA555ES for free (except shipping) but I had to make some work (helping a french guy to sell his 100 MD decks collection on MD fans forum like this one!).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...